Puppet信息泄露漏洞

CVE编号

CVE-2013-1398

利用情况

暂无

补丁情况

N/A

披露时间

2014-03-15
漏洞描述
Puppet是Puppet Labs基于ruby语言开发的自动化系统配置工具,可以以C/S 模式或独立模式运行,支持对所有UNIX及类UNIX系统的配置。pe_mcollective模块存在一个未明错误,允许攻击者利用漏洞获得对包含SSL密钥的catalog(目录)未授权访问。这些SSL密钥可用于访问其他节点或执行任意命令。
解决建议
Puppet Enterprise 2.7.1已经修复此漏洞,建议用户下载使用:https://puppetlabs.com
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet_enterprise * Up to
(including)
2.7.0
运行在以下环境
应用 puppet puppet_enterprise 2.0.0 -
运行在以下环境
应用 puppet puppet_enterprise 2.5.1 -
运行在以下环境
应用 puppet puppet_enterprise 2.5.2 -
运行在以下环境
应用 puppetlabs puppet 2.5.0 -
运行在以下环境
应用 puppetlabs puppet 2.6.0 -
CVSS3评分
8.5
  • 攻击路径
    网络
  • 攻击复杂度
    N/A
  • 权限要求
    一次
  • 影响范围
    N/A
  • 用户交互
  • 可用性
    完全地
  • 保密性
    完全地
  • 完整性
    完全地
CWE-ID 漏洞类型
阿里云安全产品覆盖情况