中危 Puppet跨站请求伪造漏洞

CVE编号

CVE-2013-1399

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-03-15
漏洞描述
Puppet是Puppet Labs基于ruby语言开发的自动化系统配置工具,可以以C/S 模式或独立模式运行,支持对所有UNIX及类UNIX系统的配置。Puppet控制台存在一个请求伪造漏洞,允许远程攻击者构建恶意URI,诱使用户解析,可以目标用户上下文执行恶意操作。
解决建议
Puppet Enterprise 2.7.1已经修复此漏洞,建议用户下载使用:https://puppetlabs.com
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet_enterprise * Up to
(including)
2.7.0
运行在以下环境
应用 puppet puppet_enterprise 2.0.0 -
运行在以下环境
应用 puppet puppet_enterprise 2.5.1 -
运行在以下环境
应用 puppet puppet_enterprise 2.5.2 -
运行在以下环境
应用 puppetlabs puppet 2.5.0 -
运行在以下环境
应用 puppetlabs puppet 2.6.0 -
阿里云评分
6.4
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-352 跨站请求伪造(CSRF)
阿里云安全产品覆盖情况