中危 Puppet 'template'和'inline_template'远程代码执行漏洞

CVE编号

CVE-2013-1640

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2013-03-21
漏洞描述
puppet是一款Linux、Unix、windows平台的集中配置管理系统。

Puppet存在远程代码执行漏洞。攻击者可以利用漏洞执行任意代码。
解决建议
Puppet 2.6.18, 2.7.21, 3.1.1, Puppet Enterprise 1.2.7, 2.7.2已经修复此漏洞,建议用户下载更新:

https://puppetlabs.com
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * Up to
(excluding)
1.2.7
运行在以下环境
应用 puppet puppet * Up to
(excluding)
2.6.18
运行在以下环境
应用 puppet puppet * From
(including)
2.7.0
Up to
(excluding)
2.7.21
运行在以下环境
应用 puppet puppet 3.1.0 -
运行在以下环境
应用 puppet puppet_enterprise 2.7.0 -
运行在以下环境
应用 puppet puppet_enterprise 2.7.1 -
运行在以下环境
系统 amazon_AMI puppet * Up to
(excluding)
2.7.21-2.11.amzn1
运行在以下环境
系统 debian_10 puppet * Up to
(excluding)
2.7.18-3
运行在以下环境
系统 debian_11 puppet * Up to
(excluding)
2.7.18-3
运行在以下环境
系统 debian_6 puppet * Up to
(excluding)
2.6.2-5+squeeze7
运行在以下环境
系统 fedora_EPEL_5 puppet-server * Up to
(excluding)
2.6.18-2.el5
运行在以下环境
系统 fedora_EPEL_6 puppet-server * Up to
(excluding)
2.6.18-2.el6
运行在以下环境
系统 suse_11 puppet * Up to
(excluding)
2.6.18-0.4
运行在以下环境
系统 ubuntu_12.04.5_lts puppet * Up to
(excluding)
2.7.11-1ubuntu2.2
阿里云评分
6.0
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况