中危 Apache HTTP Server日志内终端转义序列命令注入漏洞

CVE编号

CVE-2013-1862

利用情况

暂无

补丁情况

官方补丁

披露时间

2013-06-11
漏洞描述
Apache HTTP Server是开源HTTP服务器。

Apache HTTP Server mod_rewrite向日志文件写入数据时,没有过滤不能打印的字符。如果 mod_rewrite 使用了指令RewriteLog,远程攻击者可利用此漏洞向日志文件写入终端转义序列。如果HTTP请求包含终端模拟器的转义序列,此漏洞也可造成任意命令执行。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:http://people.apache.org/~jorton/mod_rewrite-CVE-2013-1862.patch
参考链接
http://lists.opensuse.org/opensuse-updates/2013-08/msg00026.html
http://lists.opensuse.org/opensuse-updates/2013-08/msg00029.html
http://lists.opensuse.org/opensuse-updates/2013-08/msg00030.html
http://people.apache.org/~jorton/mod_rewrite-CVE-2013-1862.patch
http://rhn.redhat.com/errata/RHSA-2013-0815.html
http://rhn.redhat.com/errata/RHSA-2013-1207.html
http://rhn.redhat.com/errata/RHSA-2013-1208.html
http://rhn.redhat.com/errata/RHSA-2013-1209.html
http://secunia.com/advisories/55032
http://support.apple.com/kb/HT6150
http://svn.apache.org/viewvc?view=revision&revision=r1469311
http://tools.cisco.com/security/center/content/CiscoSecurityNotice/CVE-2013-1862
http://www-01.ibm.com/support/docview.wss?uid=swg21644047
http://www.fujitsu.com/global/support/software/security/products-f/interstage...
http://www.mandriva.com/security/advisories?name=MDVSA-2013:174
http://www.oracle.com/technetwork/topics/security/cpujan2014-1972949.html
http://www.securityfocus.com/bid/59826
http://www.securityfocus.com/bid/64758
http://www.ubuntu.com/usn/USN-1903-1
https://bugzilla.redhat.com/show_bug.cgi?id=953729
https://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/kb/docDispla...
https://lists.apache.org/thread.html/54a42d4b01968df1117cea77fc53d6beb931c0e0...
https://lists.apache.org/thread.html/5df9bfb86a3b054bb985a45ff9250b0332c9ecc1...
https://lists.apache.org/thread.html/8d63cb8e9100f28a99429b4328e4e7cebce861d5...
https://lists.apache.org/thread.html/f7f95ac1cd9895db2714fa3ebaa0b94d0c6df360...
https://lists.apache.org/thread.html/r0276683d8e1e07153fc8642618830ac0ade85b9...
https://lists.apache.org/thread.html/r05b5357d1f6bd106f41541ee7d87aafe3f5ea4d...
https://lists.apache.org/thread.html/r2cb985de917e7da0848c440535f65a247754db8...
https://lists.apache.org/thread.html/r57608dc51b79102f3952ae06f54d5277b649c86...
https://lists.apache.org/thread.html/r5f9c22f9c28adbd9f00556059edc7b03a5d5bb7...
https://lists.apache.org/thread.html/r75cbe9ea3e2114e4271bbeca7aff96117b50c1b...
https://lists.apache.org/thread.html/r8828e649175df56f1f9e3919938ac7826128525...
https://lists.apache.org/thread.html/r9821b0a32a1d0a1b4947abb6f3630053fcbb2ec...
https://lists.apache.org/thread.html/r9b4b963760a3cb5a4a70c902f325c6c0337fe51...
https://lists.apache.org/thread.html/r9e8622254184645bc963a1d47c5d47f6d5a36d6...
https://lists.apache.org/thread.html/r9ea3538f229874c80a10af473856a81fbf5f694...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rb9c9f42dafa25d2f669dac2a536a03f2575bc5e...
https://lists.apache.org/thread.html/rdca61ae990660bacb682295f2a09d34612b7bb5...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.apache.org/thread.html/rfbaf647d52c1cb843e726a0933f156366a806ce...
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.ova...
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.ova...
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.2 -
运行在以下环境
应用 apache http_server 2.2.0 -
运行在以下环境
应用 apache http_server 2.2.1 -
运行在以下环境
应用 apache http_server 2.2.10 -
运行在以下环境
应用 apache http_server 2.2.11 -
运行在以下环境
应用 apache http_server 2.2.12 -
运行在以下环境
应用 apache http_server 2.2.13 -
运行在以下环境
应用 apache http_server 2.2.14 -
运行在以下环境
应用 apache http_server 2.2.15 -
运行在以下环境
应用 apache http_server 2.2.16 -
运行在以下环境
应用 apache http_server 2.2.17 -
运行在以下环境
应用 apache http_server 2.2.18 -
运行在以下环境
应用 apache http_server 2.2.19 -
运行在以下环境
应用 apache http_server 2.2.2 -
运行在以下环境
应用 apache http_server 2.2.20 -
运行在以下环境
应用 apache http_server 2.2.21 -
运行在以下环境
应用 apache http_server 2.2.22 -
运行在以下环境
应用 apache http_server 2.2.23 -
运行在以下环境
应用 apache http_server 2.2.24 -
运行在以下环境
应用 apache http_server 2.2.3 -
运行在以下环境
应用 apache http_server 2.2.4 -
运行在以下环境
应用 apache http_server 2.2.6 -
运行在以下环境
应用 apache http_server 2.2.8 -
运行在以下环境
应用 apache http_server 2.2.9 -
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.2.24-2.31.amzn1
运行在以下环境
系统 centos_6 httpd * Up to
(excluding)
2.2.15-28.el6.centos
运行在以下环境
系统 debian_6 httpd * Up to
(excluding)
2.2.16-6+squeeze12
运行在以下环境
系统 debian_7 httpd * Up to
(excluding)
2.2.22-13+deb7u1
运行在以下环境
系统 oracle_5 httpd * Up to
(excluding)
2.2.3-78.0.1.el5_9
运行在以下环境
系统 oracle_6 httpd * Up to
(excluding)
2.2.15-28.0.1.el6_4
运行在以下环境
系统 redhat_6 httpd * Up to
(excluding)
0:2.2.3-78.el5_9
运行在以下环境
系统 suse_11 apache2 * Up to
(excluding)
2.2.12-1.51.52
运行在以下环境
系统 ubuntu_12.04.5_lts apache2 * Up to
(excluding)
2.2.22-1ubuntu1.4
运行在以下环境
系统 ubuntu_12.04_lts apache2 * Up to
(excluding)
2.2.22-1ubuntu1.4
阿里云评分
4.0
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况