中危 Node.js up to 0.10.20 Pipelined Request Flooding 拒绝服务漏洞

CVE编号

CVE-2013-4450

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2013-10-22
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
WebCollab是一款项目流程管理软件。

Node.js实现HTTP服务时存在安全漏洞,允许远程攻击者利用漏洞发送过多管线化HTTP请求,可使应用程序崩溃造成拒绝服务攻击。
解决建议
Node.js 0.10.21和0.8.26已经修改该漏洞,建议用户下载更新:
http://nodejs.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nodejs nodejs 0.10.0 -
运行在以下环境
应用 nodejs nodejs 0.10.1 -
运行在以下环境
应用 nodejs nodejs 0.10.10 -
运行在以下环境
应用 nodejs nodejs 0.10.11 -
运行在以下环境
应用 nodejs nodejs 0.10.12 -
运行在以下环境
应用 nodejs nodejs 0.10.13 -
运行在以下环境
应用 nodejs nodejs 0.10.14 -
运行在以下环境
应用 nodejs nodejs 0.10.15 -
运行在以下环境
应用 nodejs nodejs 0.10.16 -
运行在以下环境
应用 nodejs nodejs 0.10.17 -
运行在以下环境
应用 nodejs nodejs 0.10.18 -
运行在以下环境
应用 nodejs nodejs 0.10.19 -
运行在以下环境
应用 nodejs nodejs 0.10.2 -
运行在以下环境
应用 nodejs nodejs 0.10.20 -
运行在以下环境
应用 nodejs nodejs 0.10.3 -
运行在以下环境
应用 nodejs nodejs 0.10.4 -
运行在以下环境
应用 nodejs nodejs 0.10.5 -
运行在以下环境
应用 nodejs nodejs 0.10.6 -
运行在以下环境
应用 nodejs nodejs 0.10.7 -
运行在以下环境
应用 nodejs nodejs 0.10.8 -
运行在以下环境
应用 nodejs nodejs 0.10.9 -
运行在以下环境
应用 nodejs nodejs 0.8.0 -
运行在以下环境
应用 nodejs nodejs 0.8.1 -
运行在以下环境
应用 nodejs nodejs 0.8.10 -
运行在以下环境
应用 nodejs nodejs 0.8.11 -
运行在以下环境
应用 nodejs nodejs 0.8.12 -
运行在以下环境
应用 nodejs nodejs 0.8.13 -
运行在以下环境
应用 nodejs nodejs 0.8.14 -
运行在以下环境
应用 nodejs nodejs 0.8.15 -
运行在以下环境
应用 nodejs nodejs 0.8.16 -
运行在以下环境
应用 nodejs nodejs 0.8.17 -
运行在以下环境
应用 nodejs nodejs 0.8.18 -
运行在以下环境
应用 nodejs nodejs 0.8.19 -
运行在以下环境
应用 nodejs nodejs 0.8.2 -
运行在以下环境
应用 nodejs nodejs 0.8.20 -
运行在以下环境
应用 nodejs nodejs 0.8.21 -
运行在以下环境
应用 nodejs nodejs 0.8.22 -
运行在以下环境
应用 nodejs nodejs 0.8.23 -
运行在以下环境
应用 nodejs nodejs 0.8.24 -
运行在以下环境
应用 nodejs nodejs 0.8.25 -
运行在以下环境
应用 nodejs nodejs 0.8.3 -
运行在以下环境
应用 nodejs nodejs 0.8.4 -
运行在以下环境
应用 nodejs nodejs 0.8.5 -
运行在以下环境
应用 nodejs nodejs 0.8.6 -
运行在以下环境
应用 nodejs nodejs 0.8.7 -
运行在以下环境
应用 nodejs nodejs 0.8.8 -
运行在以下环境
应用 nodejs nodejs 0.8.9 -
运行在以下环境
系统 fedora_EPEL_6 libuv * Up to
(excluding)
0.10.18-1.el6
运行在以下环境
系统 fedora_EPEL_6 libuv-debuginfo * Up to
(excluding)
0.10.18-1.el6
运行在以下环境
系统 fedora_EPEL_6 libuv-devel * Up to
(excluding)
0.10.18-1.el6
运行在以下环境
系统 ubuntu_14.04.6_lts nodejs * Up to
(excluding)
0.10.25~dfsg2-2ubuntu1
运行在以下环境
系统 ubuntu_16.04.7_lts nodejs * Up to
(excluding)
0.10.25~dfsg2-2ubuntu1
阿里云评分
5.1
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况