低危 mod_nss NSSVerifyClient设置处理目录访问限制绕过漏洞

CVE编号

CVE-2013-4566

利用情况

暂无

补丁情况

官方补丁

披露时间

2013-12-13
漏洞描述
mod_nss提供通过SSL和TLS协议对Apache web服务器进行加密的模块。

mod_nss在处理每个目录上下文的NSSVerifyClient设置时存在一个安全漏洞,允许应用程序无法执行所需的配置,允许客户端无需提供合法的客户端证书访问目录。
解决建议
用户可参考如下厂商提供的安全公告获得补丁信息:
http://rhn.redhat.com/errata/RHSA-2013-1779.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mod_nss_project mod_nss * Up to
(including)
1.0.8
运行在以下环境
应用 mod_nss_project mod_nss 1.0 -
运行在以下环境
应用 mod_nss_project mod_nss 1.0.2 -
运行在以下环境
应用 mod_nss_project mod_nss 1.0.3 -
运行在以下环境
应用 mod_nss_project mod_nss 1.0.4 -
运行在以下环境
应用 mod_nss_project mod_nss 1.0.5 -
运行在以下环境
应用 mod_nss_project mod_nss 1.0.6 -
运行在以下环境
应用 mod_nss_project mod_nss 1.0.7 -
运行在以下环境
系统 amazon_AMI mod_nss * Up to
(excluding)
1.0.8-19.12.amzn1
运行在以下环境
系统 centos_5 mod_nss * Up to
(excluding)
1.0.8-8.el5_10
运行在以下环境
系统 centos_6 mod_nss * Up to
(excluding)
1.0.8-19.el6_5
运行在以下环境
系统 oracle_5 mod_nss * Up to
(excluding)
1.0.8-8.el5_10
运行在以下环境
系统 oracle_6 mod_nss * Up to
(excluding)
1.0.8-8.el5_10
运行在以下环境
系统 redhat_6 mod_nss * Up to
(excluding)
0:1.0.8-8.el5_10
运行在以下环境
系统 suse_11_SP4 mod_nss * Up to
(excluding)
1.0.14-0.4.25.1
运行在以下环境
系统 suse_12 apache2-mod_nss * Up to
(excluding)
1.0.8-9
运行在以下环境
系统 suse_12_SP1 mod_nss * Up to
(excluding)
1.0.14-18.3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-264 权限、特权和访问控制
阿里云安全产品覆盖情况