低危 Oracle OpenJDK###Java SE 安全绕过

CVE编号

CVE-2013-4578

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-12-30
漏洞描述
在7u51之前的OpenJDK和Oracle Java SE中的jarsigner允许远程攻击者绕过代码签名保护机制,并通过利用不正确的文件验证将无符号字节码注入到签名的JAR文件中。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
http://hg.openjdk.java.net/jdk7u/jdk7u/jdk/rev/d5f36e1c927e
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 oracle jdk * Up to
(including)
1.7.0
运行在以下环境
应用 oracle jdk 1.7.0 -
运行在以下环境
应用 oracle jre * Up to
(including)
1.7.0
运行在以下环境
应用 oracle jre 1.7.0 -
运行在以下环境
系统 centos_5 java-1.7.0-openjdk * Up to
(excluding)
1.7.0.51-2.4.4.1.el5_10
运行在以下环境
系统 centos_5 java-1.7.0-openjdk-demo * Up to
(excluding)
1.7.0.51-2.4.4.1.el5_10
运行在以下环境
系统 centos_5 java-1.7.0-openjdk-devel * Up to
(excluding)
1.7.0.51-2.4.4.1.el5_10
运行在以下环境
系统 centos_5 java-1.7.0-openjdk-javadoc * Up to
(excluding)
1.7.0.51-2.4.4.1.el5_10
运行在以下环境
系统 centos_5 java-1.7.0-openjdk-src * Up to
(excluding)
1.7.0.51-2.4.4.1.el5_10
运行在以下环境
系统 centos_6 java-1.7.0-openjdk * Up to
(excluding)
1.6.0.0-3.1.13.1.el6_5
运行在以下环境
系统 centos_6 java-1.7.0-openjdk-demo * Up to
(excluding)
1.6.0.0-3.1.13.1.el6_5
运行在以下环境
系统 centos_6 java-1.7.0-openjdk-devel * Up to
(excluding)
1.6.0.0-3.1.13.1.el6_5
运行在以下环境
系统 centos_6 java-1.7.0-openjdk-javadoc * Up to
(excluding)
1.6.0.0-3.1.13.1.el6_5
运行在以下环境
系统 centos_6 java-1.7.0-openjdk-src * Up to
(excluding)
1.6.0.0-3.1.13.1.el6_5
运行在以下环境
系统 redhat_5 java-1.7.0-openjdk * Up to
(excluding)
1:1.7.0.51-2.4.4.1.el5_10
运行在以下环境
系统 redhat_6 java-1.6.0-sun * Up to
(excluding)
1:1.6.0.75-1jpp.3.el5_10
运行在以下环境
系统 ubuntu_12.04.5_lts openjdk-7 * Up to
(excluding)
7u75-2.5.4-1~precise1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-74 输出中的特殊元素转义处理不恰当(注入)
阿里云安全产品覆盖情况