Puppet Enterprise 跨站脚本漏洞和安全绕过漏洞

CVE编号

CVE-2013-4968

利用情况

暂无

补丁情况

N/A

披露时间

2019-12-12
漏洞描述
Puppet是帮助系统管理员管理基础架构的IT自动化软件。Puppet Enterprise存在跨站脚本漏洞和安全绕过漏洞。攻击者引诱用户单击透明层或不透明层上的按钮或链接,而非用户希望单击的链接,从而获取用户密码等敏感信息,执行任意代码等未授权操作。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:http://puppetlabs.com/security/cve/cve-2013-4968
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet_enterprise * From
(including)
2.0.0
Up to
(excluding)
3.0.1
CVSS3评分
6.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况