低危 Spring Framework存在多个XML外部实体注入漏洞

CVE编号

CVE-2013-6429

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-01-27
漏洞描述
Spring Framework是一个开源的Java/Java EE全功能栈(full-stack)的应用程序框架, 以Apache许可证形式发布,也有.NET平台上的移植版本。

Spring Framework在解析XML数据时SourceHttpMessageConverter存在错误,允许远程攻击者利用漏洞发送包含外部实体引用的XML数据,可获取部分本地文件内容信息。
解决建议
Spring MVC 3.2.5已经修复该漏洞,建议用户下载更新:
https://github.com/spring-projects/spring-framework?
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 pivotal_software spring_framework * From
(including)
3.0.0
Up to
(including)
3.2.4
运行在以下环境
应用 pivotal_software spring_framework 4.0.0 -
运行在以下环境
系统 debian_7 libspring-java * Up to
(excluding)
3.0.6.RELEASE-6+deb7u2
运行在以下环境
系统 ubuntu_14.04.6_lts libspring-java * Up to
(excluding)
3.0.6.RELEASE-13
运行在以下环境
系统 ubuntu_16.04.7_lts libspring-java * Up to
(excluding)
3.0.6.RELEASE-13
运行在以下环境
系统 ubuntu_18.04.5_lts libspring-java * Up to
(excluding)
3.0.6.RELEASE-13
运行在以下环境
系统 ubuntu_18.10 libspring-java * Up to
(excluding)
3.0.6.RELEASE-13
阿里云评分
3.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-352 跨站请求伪造(CSRF)
CWE-611 XML外部实体引用的不恰当限制(XXE)
阿里云安全产品覆盖情况