中危 ack存在多个代码执行漏洞

CVE编号

CVE-2013-7069

利用情况

暂无

补丁情况

官方补丁

披露时间

2013-12-15
漏洞描述
ack是一个类似Linux下的grep命令的工具。

ack存在多个安全漏洞,允许远程攻击者利用漏洞以应用程序上下文执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://openwall.com/lists/oss-security/2013/12/05/2
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 beyondgrep ack 2.00 -
运行在以下环境
应用 beyondgrep ack 2.02 -
运行在以下环境
应用 beyondgrep ack 2.04 -
运行在以下环境
应用 beyondgrep ack 2.05_01 -
运行在以下环境
应用 beyondgrep ack 2.06 -
运行在以下环境
应用 beyondgrep ack 2.08 -
运行在以下环境
应用 beyondgrep ack 2.10 -
运行在以下环境
应用 beyondgrep ack 2.11 -
运行在以下环境
应用 beyondgrep ack 2.11_01 -
运行在以下环境
应用 beyondgrep ack 2.11_02 -
运行在以下环境
系统 ubuntu_14.04_lts ack-grep * Up to
(excluding)
2.12-1
运行在以下环境
系统 ubuntu_16.04_lts ack-grep * Up to
(excluding)
2.12-1
阿里云评分
4.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况