中危 Spring Framework权限访问漏洞

CVE编号

CVE-2013-7315

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-01-24
漏洞描述
Spring Framework是一套开源的Java、Java EE应用程序框架。

Spring Framework 3.2.4之前版本,及4.0.0.M1至4.0.0.M2版本中Spring MVC存在安全漏洞。由于程序未能对StAX XMLInputFactory禁用外部实体解析,攻击者可以利用漏洞通过带有JAXB的特制XML文件读取任意文件,造成拒绝服务,并实施跨站请求伪造攻击。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:
https://jira.springsource.org/browse/SPR-10806
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 springsource spring_framework * Up to
(including)
3.2.3
运行在以下环境
应用 springsource spring_framework 3.0.0 -
运行在以下环境
应用 springsource spring_framework 3.0.0.m1 -
运行在以下环境
应用 springsource spring_framework 3.0.0.m2 -
运行在以下环境
应用 springsource spring_framework 3.0.1 -
运行在以下环境
应用 springsource spring_framework 3.0.2 -
运行在以下环境
应用 springsource spring_framework 3.0.3 -
运行在以下环境
应用 springsource spring_framework 3.0.4 -
运行在以下环境
应用 springsource spring_framework 3.0.5 -
运行在以下环境
应用 springsource spring_framework 3.0.6 -
运行在以下环境
应用 springsource spring_framework 3.0.7 -
运行在以下环境
应用 springsource spring_framework 3.1.0 -
运行在以下环境
应用 springsource spring_framework 3.1.1 -
运行在以下环境
应用 springsource spring_framework 3.1.2 -
运行在以下环境
应用 springsource spring_framework 3.1.3 -
运行在以下环境
应用 springsource spring_framework 3.1.4 -
运行在以下环境
应用 springsource spring_framework 3.2.0 -
运行在以下环境
应用 springsource spring_framework 3.2.1 -
运行在以下环境
应用 springsource spring_framework 3.2.2 -
运行在以下环境
应用 springsource spring_framework 4.0.0 -
运行在以下环境
系统 debian_7 libspring-java * Up to
(excluding)
3.0.6.RELEASE-6+deb7u1
运行在以下环境
系统 ubuntu_14.04.6_lts libspring-java * Up to
(excluding)
3.0.6.RELEASE-13
运行在以下环境
系统 ubuntu_16.04.7_lts libspring-java * Up to
(excluding)
3.2.13-5
运行在以下环境
系统 ubuntu_18.04.5_lts libspring-java * Up to
(excluding)
4.3.14-1
阿里云评分
6.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-264 权限、特权和访问控制
阿里云安全产品覆盖情况