中危 nginx SPDY请求处理堆缓冲区溢出漏洞

CVE编号

CVE-2014-0133

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-03-29
漏洞描述
nginx是一款高性能的web服务器,使用非常广泛,其不仅经常被用作反向代理,也可以非常好的支持PHP的运行。

nginx 1.4.7之前的1.3.15版本和1.5.12之前的1.5.x版本中的SPDY过程中存在堆缓冲区溢出漏洞。远程攻击者可通过特制的请求执行任意代码。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:
http://mailman.nginx.org/pipermail/nginx-announce/2014/000135.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nginx nginx * From
(including)
1.3.15
Up to
(excluding)
1.4.7
运行在以下环境
应用 nginx nginx * From
(including)
1.5.0
Up to
(including)
1.5.11
运行在以下环境
系统 amazon_AMI nginx * Up to
(excluding)
1.4.7-1.17.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.4.7-1
阿里云评分
5.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况