中危 libcURL存在多个漏洞

CVE编号

CVE-2014-0138

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-04-16
漏洞描述
cURL是一款命令行传输文件工具,支持FTP、FTPS、HTTP、HTTPS、GOPHER、TELNET、DICT、FILE和LDAP等协议。Libcurl为一个免费开源的,客户端url传输库。

libcURL存L链接重用和证书校验安全绕过漏洞,允许恶意用户进行伪造攻击和绕过安全限制。

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://curl.haxx.se/libcurl-bad-reuse.patch
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl 7.10.6 -
运行在以下环境
应用 haxx curl 7.10.7 -
运行在以下环境
应用 haxx curl 7.10.8 -
运行在以下环境
应用 haxx curl 7.11.0 -
运行在以下环境
应用 haxx curl 7.11.1 -
运行在以下环境
应用 haxx curl 7.11.2 -
运行在以下环境
应用 haxx curl 7.12.0 -
运行在以下环境
应用 haxx curl 7.12.1 -
运行在以下环境
应用 haxx curl 7.12.2 -
运行在以下环境
应用 haxx curl 7.12.3 -
运行在以下环境
应用 haxx curl 7.13.0 -
运行在以下环境
应用 haxx curl 7.13.1 -
运行在以下环境
应用 haxx curl 7.13.2 -
运行在以下环境
应用 haxx curl 7.14.0 -
运行在以下环境
应用 haxx curl 7.14.1 -
运行在以下环境
应用 haxx curl 7.15.0 -
运行在以下环境
应用 haxx curl 7.15.1 -
运行在以下环境
应用 haxx curl 7.15.2 -
运行在以下环境
应用 haxx curl 7.15.3 -
运行在以下环境
应用 haxx curl 7.15.4 -
运行在以下环境
应用 haxx curl 7.15.5 -
运行在以下环境
应用 haxx curl 7.16.0 -
运行在以下环境
应用 haxx curl 7.16.1 -
运行在以下环境
应用 haxx curl 7.16.2 -
运行在以下环境
应用 haxx curl 7.16.3 -
运行在以下环境
应用 haxx curl 7.16.4 -
运行在以下环境
应用 haxx curl 7.17.0 -
运行在以下环境
应用 haxx curl 7.17.1 -
运行在以下环境
应用 haxx curl 7.18.0 -
运行在以下环境
应用 haxx curl 7.18.1 -
运行在以下环境
应用 haxx curl 7.18.2 -
运行在以下环境
应用 haxx curl 7.19.0 -
运行在以下环境
应用 haxx curl 7.19.1 -
运行在以下环境
应用 haxx curl 7.19.2 -
运行在以下环境
应用 haxx curl 7.19.3 -
运行在以下环境
应用 haxx curl 7.19.4 -
运行在以下环境
应用 haxx curl 7.19.5 -
运行在以下环境
应用 haxx curl 7.19.6 -
运行在以下环境
应用 haxx curl 7.19.7 -
运行在以下环境
应用 haxx curl 7.20.0 -
运行在以下环境
应用 haxx curl 7.20.1 -
运行在以下环境
应用 haxx curl 7.21.0 -
运行在以下环境
应用 haxx curl 7.21.1 -
运行在以下环境
应用 haxx curl 7.21.2 -
运行在以下环境
应用 haxx curl 7.21.3 -
运行在以下环境
应用 haxx curl 7.21.4 -
运行在以下环境
应用 haxx curl 7.21.5 -
运行在以下环境
应用 haxx curl 7.21.6 -
运行在以下环境
应用 haxx curl 7.21.7 -
运行在以下环境
应用 haxx curl 7.22.0 -
运行在以下环境
应用 haxx curl 7.23.0 -
运行在以下环境
应用 haxx curl 7.23.1 -
运行在以下环境
应用 haxx curl 7.24.0 -
运行在以下环境
应用 haxx curl 7.25.0 -
运行在以下环境
应用 haxx curl 7.26.0 -
运行在以下环境
应用 haxx curl 7.27.0 -
运行在以下环境
应用 haxx curl 7.28.0 -
运行在以下环境
应用 haxx curl 7.28.1 -
运行在以下环境
应用 haxx curl 7.29.0 -
运行在以下环境
应用 haxx curl 7.30.0 -
运行在以下环境
应用 haxx curl 7.31.0 -
运行在以下环境
应用 haxx curl 7.32.0 -
运行在以下环境
应用 haxx curl 7.33.0 -
运行在以下环境
应用 haxx curl 7.34.0 -
运行在以下环境
应用 haxx curl 7.35.0 -
运行在以下环境
应用 haxx libcurl 7.10.6 -
运行在以下环境
应用 haxx libcurl 7.10.7 -
运行在以下环境
应用 haxx libcurl 7.10.8 -
运行在以下环境
应用 haxx libcurl 7.11.0 -
运行在以下环境
应用 haxx libcurl 7.11.1 -
运行在以下环境
应用 haxx libcurl 7.11.2 -
运行在以下环境
应用 haxx libcurl 7.12.0 -
运行在以下环境
应用 haxx libcurl 7.12.1 -
运行在以下环境
应用 haxx libcurl 7.12.2 -
运行在以下环境
应用 haxx libcurl 7.12.3 -
运行在以下环境
应用 haxx libcurl 7.13.0 -
运行在以下环境
应用 haxx libcurl 7.13.1 -
运行在以下环境
应用 haxx libcurl 7.13.2 -
运行在以下环境
应用 haxx libcurl 7.14.0 -
运行在以下环境
应用 haxx libcurl 7.14.1 -
运行在以下环境
应用 haxx libcurl 7.15.0 -
运行在以下环境
应用 haxx libcurl 7.15.1 -
运行在以下环境
应用 haxx libcurl 7.15.2 -
运行在以下环境
应用 haxx libcurl 7.15.3 -
运行在以下环境
应用 haxx libcurl 7.15.4 -
运行在以下环境
应用 haxx libcurl 7.15.5 -
运行在以下环境
应用 haxx libcurl 7.16.0 -
运行在以下环境
应用 haxx libcurl 7.16.1 -
运行在以下环境
应用 haxx libcurl 7.16.2 -
运行在以下环境
应用 haxx libcurl 7.16.3 -
运行在以下环境
应用 haxx libcurl 7.16.4 -
运行在以下环境
应用 haxx libcurl 7.17.0 -
运行在以下环境
应用 haxx libcurl 7.17.1 -
运行在以下环境
应用 haxx libcurl 7.18.0 -
运行在以下环境
应用 haxx libcurl 7.18.1 -
运行在以下环境
应用 haxx libcurl 7.18.2 -
运行在以下环境
应用 haxx libcurl 7.19.0 -
运行在以下环境
应用 haxx libcurl 7.19.1 -
运行在以下环境
应用 haxx libcurl 7.19.2 -
运行在以下环境
应用 haxx libcurl 7.19.3 -
运行在以下环境
应用 haxx libcurl 7.19.4 -
运行在以下环境
应用 haxx libcurl 7.19.5 -
运行在以下环境
应用 haxx libcurl 7.19.6 -
运行在以下环境
应用 haxx libcurl 7.19.7 -
运行在以下环境
应用 haxx libcurl 7.20.0 -
运行在以下环境
应用 haxx libcurl 7.20.1 -
运行在以下环境
应用 haxx libcurl 7.21.0 -
运行在以下环境
应用 haxx libcurl 7.21.1 -
运行在以下环境
应用 haxx libcurl 7.21.2 -
运行在以下环境
应用 haxx libcurl 7.21.3 -
运行在以下环境
应用 haxx libcurl 7.21.4 -
运行在以下环境
应用 haxx libcurl 7.21.5 -
运行在以下环境
应用 haxx libcurl 7.21.6 -
运行在以下环境
应用 haxx libcurl 7.21.7 -
运行在以下环境
应用 haxx libcurl 7.22.0 -
运行在以下环境
应用 haxx libcurl 7.23.0 -
运行在以下环境
应用 haxx libcurl 7.23.1 -
运行在以下环境
应用 haxx libcurl 7.24.0 -
运行在以下环境
应用 haxx libcurl 7.25.0 -
运行在以下环境
应用 haxx libcurl 7.26.0 -
运行在以下环境
应用 haxx libcurl 7.27.0 -
运行在以下环境
应用 haxx libcurl 7.28.0 -
运行在以下环境
应用 haxx libcurl 7.28.1 -
运行在以下环境
应用 haxx libcurl 7.29.0 -
运行在以下环境
应用 haxx libcurl 7.30.0 -
运行在以下环境
应用 haxx libcurl 7.31.0 -
运行在以下环境
应用 haxx libcurl 7.32.0 -
运行在以下环境
应用 haxx libcurl 7.33.0 -
运行在以下环境
应用 haxx libcurl 7.34.0 -
运行在以下环境
应用 haxx libcurl 7.35.0 -
运行在以下环境
系统 alpine_3.10 curl * Up to
(excluding)
7.36.0
运行在以下环境
系统 alpine_3.11 curl * Up to
(excluding)
7.36.0
运行在以下环境
系统 alpine_3.12 curl * Up to
(excluding)
7.36.0-r0
运行在以下环境
系统 alpine_3.13 curl * Up to
(excluding)
7.36.0-r0
运行在以下环境
系统 alpine_3.14 curl * Up to
(excluding)
7.36.0-r0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.36.0-r0
运行在以下环境
系统 alpine_3.4 curl * Up to
(excluding)
7.36.0-r0
运行在以下环境
系统 alpine_3.5 curl * Up to
(excluding)
7.36.0-r0
运行在以下环境
系统 alpine_3.6 curl * Up to
(excluding)
7.36.0
运行在以下环境
系统 alpine_3.7 curl * Up to
(excluding)
7.36.0
运行在以下环境
系统 alpine_3.8 curl * Up to
(excluding)
7.36.0
运行在以下环境
系统 alpine_3.9 curl * Up to
(excluding)
7.36.0
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.36.0-r0
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.36.0-2.44.amzn1
运行在以下环境
系统 centos_6 curl * Up to
(excluding)
7.19.7-37.el6_5.3
运行在以下环境
系统 debian_6 curl * Up to
(excluding)
7.21.0-2.1+squeeze8
运行在以下环境
系统 debian_7 curl * Up to
(excluding)
7.26.0-1+wheezy9
运行在以下环境
系统 oracle_6 curl * Up to
(excluding)
7.19.7-37.el6_5.3
运行在以下环境
系统 suse_11_SP3 curl * Up to
(excluding)
7.19.7-1.38.1
阿里云评分
5.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况