低危 Spring Framework XML DTD URI处理安全绕过漏洞

CVE编号

CVE-2014-0225

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-05-26
漏洞描述
Spring Framework是一个开源的Java/Java EE全功能栈(full-stack)的应用程序框架, 以Apache许可证形式发布,也有.NET平台上的移植版本。

Spring Framework处理XML文档DTD中的URI时存在错误,允许攻击者利用漏洞使服务器运行应用程序对反向代理后的主机执行任意HTTP GET请求,获取敏感信息。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://www.springsource.com/products/enterprise
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 pivotal_software spring_framework 3.0.0 -
运行在以下环境
应用 pivotal_software spring_framework 3.0.1 -
运行在以下环境
应用 pivotal_software spring_framework 3.0.2 -
运行在以下环境
应用 pivotal_software spring_framework 3.0.3 -
运行在以下环境
应用 pivotal_software spring_framework 3.0.4 -
运行在以下环境
应用 pivotal_software spring_framework 3.0.5 -
运行在以下环境
应用 pivotal_software spring_framework 3.0.6 -
运行在以下环境
应用 pivotal_software spring_framework 3.0.7 -
运行在以下环境
应用 pivotal_software spring_framework 3.1.0 -
运行在以下环境
应用 pivotal_software spring_framework 3.1.1 -
运行在以下环境
应用 pivotal_software spring_framework 3.1.2 -
运行在以下环境
应用 pivotal_software spring_framework 3.1.3 -
运行在以下环境
应用 pivotal_software spring_framework 3.1.4 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.0 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.1 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.2 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.3 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.4 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.5 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.6 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.7 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.8 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.0 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.1 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.2 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.3 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.4 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
3.0.6.RELEASE-14
运行在以下环境
系统 ubuntu_16.04.7_lts libspring-java * Up to
(excluding)
3.0.6.RELEASE-14
运行在以下环境
系统 ubuntu_16.04_lts libspring-java * Up to
(excluding)
3.0.6.RELEASE-14
运行在以下环境
系统 ubuntu_18.04.5_lts libspring-java * Up to
(excluding)
3.0.6.RELEASE-14
运行在以下环境
系统 ubuntu_18.04_lts libspring-java * Up to
(excluding)
3.0.6.RELEASE-14
运行在以下环境
系统 ubuntu_18.10 libspring-java * Up to
(excluding)
3.0.6.RELEASE-14
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-611 XML外部实体引用的不恰当限制(XXE)
阿里云安全产品覆盖情况