低危 LibreOffice 'sfx2/source/doc/docmacromode.cxx' VBA脚本代码执行漏洞

CVE编号

CVE-2014-0247

利用情况

暂无

补丁情况

缓解措施

披露时间

2014-07-04
漏洞描述
LibreOffice是一套可与其他主要办公室软体相容的套件,可在各种平台上执行。

LibreOffice 'sfx2/source/doc/docmacromode.cxx'存在VBA脚本代码执行漏洞,允许上下文相关的攻击者执行VBA脚本代码。
解决建议
用户可以联系供应商获得补丁信息:
http://www.libreoffice.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libreoffice libreoffice 4.2.4 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1:4.2.5-1
运行在以下环境
系统 fedoraproject fedora 19 -
运行在以下环境
系统 opensuse opensuse 13.1 -
运行在以下环境
系统 oracle linux_7 autocorr-ca * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 autocorr-da * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 autocorr-es * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 autocorr-fa * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 autocorr-fi * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 autocorr-is * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 autocorr-ru * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libabw-tools * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libcmis * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libetonyek * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libetonyek-doc * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 liblangtag-gobject * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libodfgen * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoff * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-gdb-debug-support * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-langpack-de * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-langpack-ga * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-langpack-gl * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-langpack-kk * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-langpack-ko * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-langpack-lv * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-langpack-nb * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-langpack-nso * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-langpack-pt-BR * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-librelogo * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-pyuno * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-sdk-doc * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 libreoffice-xsltfilter * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle linux_7 mdds-devel * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 oracle_7 libreoffice-langpack-cy * Up to
(excluding)
4.2.6.3-5.0.1.el7
运行在以下环境
系统 redhat enterprise_linux_desktop 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server 7.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 7.0 -
运行在以下环境
系统 redhat_7 mdds-devel * Up to
(excluding)
0:0.10.3-1.el7
运行在以下环境
系统 sles_12 libreoffice * Up to
(excluding)
4.3.1.2-3
运行在以下环境
系统 suse_12 libreoffice * Up to
(excluding)
4.3.1.2-3
运行在以下环境
系统 ubuntu_12.04.5_lts libreoffice * Up to
(excluding)
1:3.5.7-0ubuntu5
运行在以下环境
系统 ubuntu_12.04_lts libreoffice * Up to
(excluding)
1:3.5.7-0ubuntu5
运行在以下环境
系统 ubuntu_14.04.6_lts libreoffice * Up to
(excluding)
1:4.2.4-0ubuntu2
运行在以下环境
系统 ubuntu_14.04_lts libreoffice * Up to
(excluding)
1:4.2.4-0ubuntu2
阿里云评分
3.7
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    缓解措施
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况