中危 apt安全绕过漏洞

CVE编号

CVE-2014-0478

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-06-18
漏洞描述
apt是一款软件包管理工具。

apt存在安全绕过漏洞,当从"apt-get source"中获取源包时,apt没有对源包进行验证检查,允许攻击者利用漏洞安装恶意包。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://bugs.debian.org/cgi-bin/bugreport.cgi?msg=83;filename=apt_0.8.10.3%2Bsqueeze2.debdiff;att=1;bug=749795
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 debian advanced_package_tool * Up to
(including)
1.0.3
运行在以下环境
系统 debian_6 apt * Up to
(excluding)
0.8.10.3+squeeze2
运行在以下环境
系统 debian_7 apt * Up to
(excluding)
0.9.7.9+deb7u2
运行在以下环境
系统 ubuntu_12.04.5_lts apt * Up to
(excluding)
0.8.16~exp12ubuntu10.17
运行在以下环境
系统 ubuntu_14.04 apt * Up to
(excluding)
1.0.1ubuntu2.1
运行在以下环境
系统 ubuntu_14.04.6_lts apt * Up to
(excluding)
1.0.1ubuntu2.1
阿里云评分
5.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况