Puppet安全绕过漏洞(CNVD-2014-03754)

CVE编号

CVE-2014-3249

利用情况

暂无

补丁情况

N/A

披露时间

2014-06-18
漏洞描述
Puppet是Puppet Labs基于ruby语言开发的自动化系统配置工具,可以以C/S 模式或独立模式运行,支持对所有UNIX及类UNIX系统的配置。

Puppet未能正确限制对节点的访问,允许攻击者利用漏洞在控制台隐藏和显示节点或获得节点列表。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://puppetlabs.com
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet_enterprise 2.8.0 -
运行在以下环境
应用 puppet puppet_enterprise 2.8.1 -
运行在以下环境
应用 puppet puppet_enterprise 2.8.2 -
运行在以下环境
应用 puppet puppet_enterprise 2.8.3 -
运行在以下环境
应用 puppet puppet_enterprise 2.8.4 -
运行在以下环境
应用 puppet puppet_enterprise 2.8.5 -
运行在以下环境
应用 puppet puppet_enterprise 2.8.6 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
CVSS3评分
5.0
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    N/A
  • 用户交互
  • 可用性
  • 保密性
    部分地
  • 完整性
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况