低危 Puppet信息泄露漏洞(CNVD-2017-38115)

CVE编号

CVE-2014-3250

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-12-12
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具。该工具可用于管理配置文件、用户、cron任务、软件包、系统服务等。

Puppet 3.6.2之前的版本中默认的vhost配置文件存在信息泄露漏洞。远程攻击者可借助被调用的证书利用该漏洞获取敏感信息。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://puppet.com/security/cve/CVE-2014-3250
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.4.0 -
运行在以下环境
应用 puppet puppet * Up to
(excluding)
3.6.2
运行在以下环境
系统 debian DPKG * Up to
(excluding)
3.7.0-1
运行在以下环境
系统 suse_11 puppet * Up to
(excluding)
2.7.26-0.5
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况