低危 GNU Emacs后置链接漏洞

CVE编号

CVE-2014-3424

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-05-08
漏洞描述
GNU Emacs是GNU计划开发的一个使用C语言编写的Unix文本编辑器,它支持语法高亮显示、多种语言和功能扩展等。

GNU Emacs 24.3及之前版本的lisp/net/tramp-sh.el文件中存在安全漏洞。本地攻击者可通过对/tmp/tramp.#####临时文件实施符号链接攻击利用该漏洞覆盖任意文件。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,请到厂商主页下载:
http://www.gnu.org/software/emacs/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu emacs * Up to
(including)
24.3
运行在以下环境
应用 gnu emacs 20.0 -
运行在以下环境
应用 gnu emacs 20.1 -
运行在以下环境
应用 gnu emacs 20.2 -
运行在以下环境
应用 gnu emacs 20.3 -
运行在以下环境
应用 gnu emacs 20.4 -
运行在以下环境
应用 gnu emacs 20.5 -
运行在以下环境
应用 gnu emacs 20.6 -
运行在以下环境
应用 gnu emacs 20.7 -
运行在以下环境
应用 gnu emacs 21 -
运行在以下环境
应用 gnu emacs 21.1 -
运行在以下环境
应用 gnu emacs 21.2 -
运行在以下环境
应用 gnu emacs 21.2.1 -
运行在以下环境
应用 gnu emacs 21.3 -
运行在以下环境
应用 gnu emacs 21.3.1 -
运行在以下环境
应用 gnu emacs 21.4 -
运行在以下环境
应用 gnu emacs 22.1 -
运行在以下环境
应用 gnu emacs 22.2 -
运行在以下环境
应用 gnu emacs 22.3 -
运行在以下环境
应用 gnu emacs 23.1 -
运行在以下环境
应用 gnu emacs 23.2 -
运行在以下环境
应用 gnu emacs 23.3 -
运行在以下环境
应用 gnu emacs 23.4 -
运行在以下环境
应用 gnu emacs 24.1 -
运行在以下环境
应用 gnu emacs 24.2 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 mageia_project mageia 3 -
运行在以下环境
系统 mageia_project mageia 4 -
运行在以下环境
系统 sles_11_SP3 emacs * Up to
(excluding)
22.3-4.42.1
运行在以下环境
系统 sles_11_SP3 emacs-info * Up to
(excluding)
22.3-4.42.1
运行在以下环境
系统 sles_11_SP3 emacs-x11 * Up to
(excluding)
22.3-4.42.1
运行在以下环境
系统 sles_12 emacs * Up to
(excluding)
24.3-14
运行在以下环境
系统 suse_11_SP3 emacs * Up to
(excluding)
22.3-4.42.1
运行在以下环境
系统 suse_12 emacs * Up to
(excluding)
24.3-14
运行在以下环境
系统 ubuntu_12.04.5_lts xemacs21 * Up to
(excluding)
code-not-present
运行在以下环境
系统 ubuntu_12.04_lts xemacs21 * Up to
(excluding)
code-not-present
运行在以下环境
系统 ubuntu_14.04.6_lts xemacs21 * Up to
(excluding)
code-not-present
运行在以下环境
系统 ubuntu_14.04_lts xemacs21 * Up to
(excluding)
code-not-present
运行在以下环境
系统 ubuntu_16.04.7_lts emacs24 * Up to
(excluding)
24.5+1-6ubuntu1
运行在以下环境
系统 ubuntu_16.04_lts emacs24 * Up to
(excluding)
24.5+1-6ubuntu1
运行在以下环境
系统 ubuntu_18.04.5_lts xemacs21 * Up to
(excluding)
code-not-present
运行在以下环境
系统 ubuntu_18.04_lts xemacs21 * Up to
(excluding)
code-not-present
阿里云评分
3.3
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-59 在文件访问前对链接解析不恰当(链接跟随)
阿里云安全产品覆盖情况