低危 PHP unserialize()函数类型混淆漏洞

CVE编号

CVE-2014-3515

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-07-10 00:07:00
漏洞描述
PHP是一款流行的编程语言。

PHP unserialize()函数SPL ArrayObject / SPLObjectStorage存在类型混淆漏洞,允许攻击者利用漏洞使应用程序崩溃。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://www.php.net/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * Up to
(including)
5.4.29
运行在以下环境
应用 php php 5.4.0 -
运行在以下环境
应用 php php 5.4.1 -
运行在以下环境
应用 php php 5.4.10 -
运行在以下环境
应用 php php 5.4.11 -
运行在以下环境
应用 php php 5.4.12 -
运行在以下环境
应用 php php 5.4.13 -
运行在以下环境
应用 php php 5.4.14 -
运行在以下环境
应用 php php 5.4.15 -
运行在以下环境
应用 php php 5.4.16 -
运行在以下环境
应用 php php 5.4.17 -
运行在以下环境
应用 php php 5.4.18 -
运行在以下环境
应用 php php 5.4.19 -
运行在以下环境
应用 php php 5.4.2 -
运行在以下环境
应用 php php 5.4.20 -
运行在以下环境
应用 php php 5.4.21 -
运行在以下环境
应用 php php 5.4.22 -
运行在以下环境
应用 php php 5.4.23 -
运行在以下环境
应用 php php 5.4.24 -
运行在以下环境
应用 php php 5.4.25 -
运行在以下环境
应用 php php 5.4.26 -
运行在以下环境
应用 php php 5.4.27 -
运行在以下环境
应用 php php 5.4.28 -
运行在以下环境
应用 php php 5.4.3 -
运行在以下环境
应用 php php 5.4.4 -
运行在以下环境
应用 php php 5.4.5 -
运行在以下环境
应用 php php 5.4.6 -
运行在以下环境
应用 php php 5.4.7 -
运行在以下环境
应用 php php 5.4.8 -
运行在以下环境
应用 php php 5.4.9 -
运行在以下环境
应用 php php 5.5.0 -
运行在以下环境
应用 php php 5.5.1 -
运行在以下环境
应用 php php 5.5.10 -
运行在以下环境
应用 php php 5.5.11 -
运行在以下环境
应用 php php 5.5.12 -
运行在以下环境
应用 php php 5.5.13 -
运行在以下环境
应用 php php 5.5.2 -
运行在以下环境
应用 php php 5.5.3 -
运行在以下环境
应用 php php 5.5.4 -
运行在以下环境
应用 php php 5.5.5 -
运行在以下环境
应用 php php 5.5.6 -
运行在以下环境
应用 php php 5.5.7 -
运行在以下环境
应用 php php 5.5.8 -
运行在以下环境
应用 php php 5.5.9 -
运行在以下环境
系统 amazon_AMI php * Up to
(excluding)
5.3.29-1.7.amzn1
运行在以下环境
系统 centos_6 php * Up to
(excluding)
27.el6_5.1
运行在以下环境
系统 centos_7 php * Up to
(excluding)
5.4.16-23.el7_0
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.0~rc2+dfsg-1
运行在以下环境
系统 oracle_5 php * Up to
(excluding)
5.3.3-23.el5_10
运行在以下环境
系统 oracle_6 php * Up to
(excluding)
5.3.3-23.el5_10
运行在以下环境
系统 oracle_7 php * Up to
(excluding)
5.4.16-23.el7_0
运行在以下环境
系统 redhat_6 php53 * Up to
(excluding)
0:5.3.3-23.el5_10
运行在以下环境
系统 redhat_7 php * Up to
(excluding)
0:5.4.16-23.el7_0
运行在以下环境
系统 suse_11 apache2-mod_php53 * Up to
(excluding)
5.3.17-0.41
运行在以下环境
系统 ubuntu_12.04_lts php5 * Up to
(excluding)
5.3.10-1ubuntu3.13
运行在以下环境
系统 ubuntu_14.04 php * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.3
运行在以下环境
系统 ubuntu_14.04_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.3
阿里云评分
3.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况