Apple MacOS X up to 10.10.2 Apache 拒绝服务漏洞

CVE编号

CVE-2014-3523

利用情况

暂无

补丁情况

N/A

披露时间

2014-07-21
漏洞描述
Apache HTTP Server是一款基于Apache的服务程序。

Apache HTTP Server 2.4.9, 2.4.8, 2.4.7, 2.4.6版本启用了默认AcceptFilter后,WinNT MPM中server/mpm/winnt/child.c的函数winnt_accept存在内存泄露,允许远程攻击者通过特制的请求数据,利用此漏洞发起拒绝服务攻击(资源耗尽)。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://httpd.apache.org/security/vulnerabilities_24.html
参考链接
http://httpd.apache.org/security/vulnerabilities_24.html
http://marc.info/?l=bugtraq&m=143748090628601&w=2
http://marc.info/?l=bugtraq&m=144050155601375&w=2
http://rhn.redhat.com/errata/RHSA-2016-2957.html
http://svn.apache.org/viewvc/httpd/httpd/trunk/server/mpm/winnt/child.c
http://svn.apache.org/viewvc/httpd/httpd/trunk/server/mpm/winnt/child.c?r1=16...
http://www.securityfocus.com/bid/68747
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/r476d175be0aaf4a17680ef98c5153b4d336eaef...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r83109088737656fa6307bd99ab40f8ff0269ae5...
https://lists.apache.org/thread.html/r9821b0a32a1d0a1b4947abb6f3630053fcbb2ec...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/ra7f6aeb28661fbf826969526585f16856abc461...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rcc44594d4d6579b90deccd4536b5d31f099ef56...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rd336919f655b7ff309385e34a143e41c503e133...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.4.1 -
运行在以下环境
应用 apache http_server 2.4.2 -
运行在以下环境
应用 apache http_server 2.4.3 -
运行在以下环境
应用 apache http_server 2.4.4 -
运行在以下环境
应用 apache http_server 2.4.6 -
运行在以下环境
应用 apache http_server 2.4.7 -
运行在以下环境
应用 apache http_server 2.4.8 -
运行在以下环境
应用 apache http_server 2.4.9 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 suse_12 apache2 * Up to
(excluding)
2.4.10-6
CVSS3评分
5.0
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    N/A
  • 用户交互
  • 可用性
    部分地
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况