低危 OpenSSL ‘ssl3_get_key_exchange’函数加密问题漏洞

CVE编号

CVE-2014-3572

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-01-09 15:59:00
漏洞描述
OpenSSL是OpenSSL团队开发的一个开源的能够实现安全套接层(SSL v2/v3)和安全传输层(TLS v1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。
OpenSSL的文件中的函数存在安全漏洞。远程攻击者可利用该漏洞实施ECDHE-to-ECDH降级攻击,删除密码套件中的正向加密。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:https://www.openssl.org/news/secadv_20150108.txt
参考链接
http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10679
http://lists.apple.com/archives/security-announce/2015/Apr/msg00001.html
http://lists.opensuse.org/opensuse-security-announce/2015-01/msg00021.html
http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00027.html
http://lists.opensuse.org/opensuse-security-announce/2015-05/msg00026.html
http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00037.html
http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00011.html
http://marc.info/?l=bugtraq&m=142496179803395&w=2
http://marc.info/?l=bugtraq&m=142496289803847&w=2
http://marc.info/?l=bugtraq&m=142720981827617&w=2
http://marc.info/?l=bugtraq&m=142721102728110&w=2
http://marc.info/?l=bugtraq&m=142895206924048&w=2
http://marc.info/?l=bugtraq&m=143748090628601&w=2
http://marc.info/?l=bugtraq&m=144050155601375&w=2
http://marc.info/?l=bugtraq&m=144050205101530&w=2
http://marc.info/?l=bugtraq&m=144050254401665&w=2
http://marc.info/?l=bugtraq&m=144050297101809&w=2
http://rhn.redhat.com/errata/RHSA-2015-0066.html
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa...
http://www.debian.org/security/2015/dsa-3125
http://www.mandriva.com/security/advisories?name=MDVSA-2015:019
http://www.mandriva.com/security/advisories?name=MDVSA-2015:062
http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html
http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
http://www.oracle.com/technetwork/topics/security/bulletinjan2015-2370101.html
http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html
http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html
http://www.oracle.com/technetwork/topics/security/cpuoct2015-2367953.html
http://www.securityfocus.com/bid/71942
http://www.securitytracker.com/id/1033378
https://bto.bluecoat.com/security-advisory/sa88
https://github.com/openssl/openssl/commit/b15f8769644b00ef7283521593360b7b2135cb63
https://kc.mcafee.com/corporate/index?page=content&id=SB10102
https://kc.mcafee.com/corporate/index?page=content&id=SB10108
https://support.apple.com/HT204659
https://support.citrix.com/article/CTX216642
https://www.openssl.org/news/secadv_20150108.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl 1.0.0e -
运行在以下环境
应用 openssl openssl 1.0.0f -
运行在以下环境
应用 openssl openssl 1.0.0g -
运行在以下环境
应用 openssl openssl 1.0.0h -
运行在以下环境
应用 openssl openssl 1.0.0i -
运行在以下环境
应用 openssl openssl 1.0.0j -
运行在以下环境
应用 openssl openssl 1.0.0k -
运行在以下环境
应用 openssl openssl 1.0.0l -
运行在以下环境
应用 openssl openssl 1.0.0m -
运行在以下环境
应用 openssl openssl 1.0.0n -
运行在以下环境
应用 openssl openssl 1.0.0o -
运行在以下环境
应用 openssl openssl 1.0.1a -
运行在以下环境
应用 openssl openssl 1.0.1b -
运行在以下环境
应用 openssl openssl 1.0.1c -
运行在以下环境
应用 openssl openssl 1.0.1d -
运行在以下环境
应用 openssl openssl 1.0.1e -
运行在以下环境
应用 openssl openssl 1.0.1f -
运行在以下环境
应用 openssl openssl 1.0.1g -
运行在以下环境
应用 openssl openssl 1.0.1h -
运行在以下环境
应用 openssl openssl 1.0.1i -
运行在以下环境
应用 openssl openssl 1.0.1j -
运行在以下环境
应用 openssl openssl * Up to
(including)
0.9.8zc
运行在以下环境
应用 openssl openssl 1.0.0a -
运行在以下环境
应用 openssl openssl 1.0.0b -
运行在以下环境
应用 openssl openssl 1.0.0c -
运行在以下环境
应用 openssl openssl 1.0.0d -
2
运行在以下环境
系统 redhat_7 openssl * Up to
(excluding)
1:1.0.1e-34.el7_0.7
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.0.1k-1
运行在以下环境
系统 ubuntu_16.04_lts openssl * Up to
(excluding)
1.0.1f-1ubuntu10
运行在以下环境
系统 ubuntu_14.04_lts openssl * Up to
(excluding)
1.0.1f-1ubuntu2.8
运行在以下环境
系统 ubuntu_12.04_lts openssl * Up to
(excluding)
1.0.1-4ubuntu5.21
运行在以下环境
系统 ubuntu_18.04_lts openssl * Up to
(excluding)
1.0.1f-1ubuntu10
运行在以下环境
系统 ubuntu_18.10 openssl * Up to
(excluding)
1.0.1f-1ubuntu10
运行在以下环境
系统 suse_12 libopenssl1_0_0 * Up to
(excluding)
1.0.1i-34
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
阿里云安全产品覆盖情况