低危 Spring Framework存在未明远程目录遍历漏洞

CVE编号

CVE-2014-3578

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-02-20
漏洞描述
Spring Framework是一个开源的Java/Java EE全功能栈(full-stack)的应用程序框架, 以Apache许可证形式发布,也有.NET平台。

Spring Framework存在未明目录遍历漏洞,允许远程攻击者利用漏洞提交特殊的请求以WEB权限查看系统文件内容。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://projects.spring.io/spring-framework/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 pivotal_software spring_framework * From
(including)
3.2.0
Up to
(excluding)
3.2.9
运行在以下环境
应用 pivotal_software spring_framework * From
(including)
4.0.0
Up to
(excluding)
4.0.5
运行在以下环境
系统 debian DPKG * Up to
(excluding)
3.2.13-1
运行在以下环境
系统 debian_8 libspring-java * Up to
(excluding)
3.0.6.RELEASE-17+deb8u1
运行在以下环境
系统 ubuntu_16.04.7_lts libspring-java * Up to
(excluding)
3.2.12-1
运行在以下环境
系统 ubuntu_18.04.5_lts libspring-java * Up to
(excluding)
3.2.12-1
运行在以下环境
系统 ubuntu_18.10 libspring-java * Up to
(excluding)
3.2.12-1
阿里云评分
3.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-22 对路径名的限制不恰当(路径遍历)
阿里云安全产品覆盖情况