低危 Apache HTTP Server mod_cache Content-type 资源管理漏洞

CVE编号

CVE-2014-3581

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-10-10
漏洞描述
Apache HTTP Server是Apache软件基金会的一个开放源码的网页服务器。

Apache HTTP Server 2.4.10版本在"cache_merge_headers_out()"函数(modules/cache/cache_util.c)中存在空指针间接引用错误,攻击者利用此漏洞可通过值为空的content-type字段造成服务器崩溃。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://svn.apache.org/viewvc/httpd/httpd/branches/2.4.x/CHANGES?view=markup&pathrev=1627749
参考链接
http://lists.apple.com/archives/security-announce/2015/Aug/msg00001.html
http://lists.apple.com/archives/security-announce/2015/Sep/msg00004.html
http://rhn.redhat.com/errata/RHSA-2015-0325.html
http://svn.apache.org/viewvc/httpd/httpd/branches/2.4.x/CHANGES?view=markup&p...
http://svn.apache.org/viewvc?view=revision&revision=1624234
http://www.oracle.com/technetwork/topics/security/cpujan2016-2367955.html
http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
http://www.securityfocus.com/bid/71656
http://www.securitytracker.com/id/1031005
http://www.ubuntu.com/usn/USN-2523-1
https://bugzilla.redhat.com/show_bug.cgi?id=1149709
https://exchange.xforce.ibmcloud.com/vulnerabilities/97027
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/r476d175be0aaf4a17680ef98c5153b4d336eaef...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r83109088737656fa6307bd99ab40f8ff0269ae5...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/ra7f6aeb28661fbf826969526585f16856abc461...
https://lists.apache.org/thread.html/rb14daf9cc4e28d18cdc15d6a6ca74e565672fab...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rcc44594d4d6579b90deccd4536b5d31f099ef56...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rd336919f655b7ff309385e34a143e41c503e133...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://security.gentoo.org/glsa/201610-02
https://support.apple.com/HT205219
https://support.apple.com/kb/HT205031
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache apache_http_server * Up to
(including)
2.4.10
运行在以下环境
应用 apache apache_http_server 2.4.0 -
运行在以下环境
应用 apache apache_http_server 2.4.1 -
运行在以下环境
应用 apache apache_http_server 2.4.2 -
运行在以下环境
应用 apache apache_http_server 2.4.3 -
运行在以下环境
应用 apache apache_http_server 2.4.4 -
运行在以下环境
应用 apache apache_http_server 2.4.5 -
运行在以下环境
应用 apache apache_http_server 2.4.6 -
运行在以下环境
应用 apache apache_http_server 2.4.7 -
运行在以下环境
应用 apache apache_http_server 2.4.8 -
运行在以下环境
应用 apache apache_http_server 2.4.9 -
运行在以下环境
系统 amazon_AMI apache2 * Up to
(excluding)
2.4.10-15.58.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.4.10-3
运行在以下环境
系统 debian_6 apache2 * Up to
(excluding)
2.2.16-6+squeeze14
运行在以下环境
系统 fedora_21 apache2 * Up to
(excluding)
2.4.10-15.fc21
运行在以下环境
系统 oracle_6 apache2 * Up to
(excluding)
2.4.6-22.0.1.el6
运行在以下环境
系统 oracle_7 apache2 * Up to
(excluding)
2.4.6-31.0.1.el7
运行在以下环境
系统 redhat_7 httpd * Up to
(excluding)
0:2.4.6-31.el7
运行在以下环境
系统 suse_12 apache2 * Up to
(excluding)
2.4.10-12.1
运行在以下环境
系统 ubuntu_12.04.5_lts apache2 * Up to
(excluding)
2.2.22-1ubuntu1.7
运行在以下环境
系统 ubuntu_14.04 apache2 * Up to
(excluding)
2.4.7-1ubuntu4.4
运行在以下环境
系统 ubuntu_14.04.6_lts apache2 * Up to
(excluding)
2.4.7-1ubuntu4.4
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况