低危 Apache Axis Incomplete Fix SSL证书验证安全绕过漏洞

CVE编号

CVE-2014-3596

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-08-27
漏洞描述
Apache Axis是Apache web services/SOAP/WDSL引擎,它是Apache SOAP项目的延续。

Apache Axis存在安全绕过漏洞,该漏洞是因为应用程序未能能正确地验证SSL证书。允许攻击者利用漏洞进行中间人攻击或冒充受信任的服务器。

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://www.apache.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache axis * Up to
(including)
1.4
运行在以下环境
应用 apache axis 1.0 -
运行在以下环境
应用 apache axis 1.1 -
运行在以下环境
应用 apache axis 1.2 -
运行在以下环境
应用 apache axis 1.2.1 -
运行在以下环境
应用 apache axis 1.3 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.4-21
运行在以下环境
系统 redhat_6 axis * Up to
(excluding)
0:1.2.1-2jpp.8.el5_10
运行在以下环境
系统 suse_12 axis * Up to
(excluding)
1.4-290.6
运行在以下环境
系统 ubuntu_14.04.6_lts axis * Up to
(excluding)
1.4-20ubuntu3
运行在以下环境
系统 ubuntu_14.04_lts axis * Up to
(excluding)
1.4-20ubuntu3
阿里云评分
3.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况