低危 nginx SSL会话固定漏洞

CVE编号

CVE-2014-3616

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-12-09
漏洞描述
nginx是一款使用非常广泛的高性能web服务器。

nginx 0.5.6-1.7.4版本在实现上存在会话固定漏洞,攻击者可利用此漏洞劫持任意会话或访问敏感信息。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://nginx.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nginx nginx * From
(including)
0.5.6
Up to
(excluding)
1.6.2
运行在以下环境
应用 nginx nginx * From
(including)
1.7.0
Up to
(excluding)
1.7.5
运行在以下环境
系统 amazon_AMI nginx * Up to
(excluding)
1.6.2-1.22.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.6.2-1
运行在以下环境
系统 debian_6 nginx * Up to
(excluding)
0.7.67-3+squeeze4
运行在以下环境
系统 debian_7 nginx * Up to
(excluding)
1.2.1-2.2+wheezy3
运行在以下环境
系统 fedora_21 nginx * Up to
(excluding)
1.6.2-2.fc21
运行在以下环境
系统 fedora_EPEL_6 nginx * Up to
(excluding)
1.0.15-8.el6
运行在以下环境
系统 fedora_EPEL_7 nginx * Up to
(excluding)
1.6.2-1.el7
运行在以下环境
系统 oracle_8 nginx * Up to
(excluding)
1.16.1-1.0.1.module+el8.3.0+7892+37ea59a5.1
运行在以下环境
系统 ubuntu_12.04.5_lts nginx * Up to
(excluding)
1.1.19-1ubuntu0.7
运行在以下环境
系统 ubuntu_14.04 nginx * Up to
(excluding)
1.4.6-1ubuntu3.1
运行在以下环境
系统 ubuntu_14.04.6_lts nginx * Up to
(excluding)
1.4.6-1ubuntu3.1
阿里云评分
3.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-613 不充分的会话过期机制
阿里云安全产品覆盖情况