低危 PHP 'libxmlrpc/xmlrpc.c'缓冲区溢出漏洞

CVE编号

CVE-2014-3668

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-10-29
漏洞描述
PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。

PHP 'libxmlrpc/xmlrpc.c'存在缓冲区溢出漏洞,攻击者可以利用此漏洞在受影响应用程序的上下文中执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://php.net/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * Up to
(including)
5.4.33
运行在以下环境
应用 php php 5.4.0 -
运行在以下环境
应用 php php 5.4.1 -
运行在以下环境
应用 php php 5.4.10 -
运行在以下环境
应用 php php 5.4.11 -
运行在以下环境
应用 php php 5.4.12 -
运行在以下环境
应用 php php 5.4.13 -
运行在以下环境
应用 php php 5.4.14 -
运行在以下环境
应用 php php 5.4.15 -
运行在以下环境
应用 php php 5.4.16 -
运行在以下环境
应用 php php 5.4.17 -
运行在以下环境
应用 php php 5.4.18 -
运行在以下环境
应用 php php 5.4.19 -
运行在以下环境
应用 php php 5.4.2 -
运行在以下环境
应用 php php 5.4.20 -
运行在以下环境
应用 php php 5.4.21 -
运行在以下环境
应用 php php 5.4.22 -
运行在以下环境
应用 php php 5.4.23 -
运行在以下环境
应用 php php 5.4.24 -
运行在以下环境
应用 php php 5.4.25 -
运行在以下环境
应用 php php 5.4.26 -
运行在以下环境
应用 php php 5.4.27 -
运行在以下环境
应用 php php 5.4.28 -
运行在以下环境
应用 php php 5.4.29 -
运行在以下环境
应用 php php 5.4.3 -
运行在以下环境
应用 php php 5.4.30 -
运行在以下环境
应用 php php 5.4.31 -
运行在以下环境
应用 php php 5.4.32 -
运行在以下环境
应用 php php 5.4.4 -
运行在以下环境
应用 php php 5.4.5 -
运行在以下环境
应用 php php 5.4.6 -
运行在以下环境
应用 php php 5.4.7 -
运行在以下环境
应用 php php 5.4.8 -
运行在以下环境
应用 php php 5.4.9 -
运行在以下环境
应用 php php 5.5.0 -
运行在以下环境
应用 php php 5.5.1 -
运行在以下环境
应用 php php 5.5.10 -
运行在以下环境
应用 php php 5.5.11 -
运行在以下环境
应用 php php 5.5.12 -
运行在以下环境
应用 php php 5.5.13 -
运行在以下环境
应用 php php 5.5.14 -
运行在以下环境
应用 php php 5.5.15 -
运行在以下环境
应用 php php 5.5.16 -
运行在以下环境
应用 php php 5.5.17 -
运行在以下环境
应用 php php 5.5.2 -
运行在以下环境
应用 php php 5.5.3 -
运行在以下环境
应用 php php 5.5.4 -
运行在以下环境
应用 php php 5.5.5 -
运行在以下环境
应用 php php 5.5.6 -
运行在以下环境
应用 php php 5.5.7 -
运行在以下环境
应用 php php 5.5.8 -
运行在以下环境
应用 php php 5.5.9 -
运行在以下环境
应用 php php 5.6.0 -
运行在以下环境
应用 php php 5.6.1 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.2+dfsg-1
运行在以下环境
系统 redhat_5 php53 * Up to
(excluding)
0:5.3.3-26.el5_11
运行在以下环境
系统 redhat_7 php * Up to
(excluding)
0:5.4.16-23.el7_0.3
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-7
运行在以下环境
系统 ubuntu_12.04_lts php5 * Up to
(excluding)
5.3.10-1ubuntu3.15
运行在以下环境
系统 ubuntu_14.04_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.5
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况