低危 cgiHttpServer模块无法正确处理URL中的URL编码路径分隔符

CVE编号

CVE-2014-4650

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-02-21
漏洞描述
据发现,CGIHTTPServer模块错误地处理了URL编码路径。远程攻击者可以使用此漏洞执行cgi-bin目录之外的脚本,或者在cgi-bin目录中公开脚本源。

解决建议
用户可参考如下厂商提供的安全公告获取补丁以修复该漏洞:http://bugs.python.org/issue21766
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python python 2.7.5 -
运行在以下环境
应用 python python 3.3.4 -
运行在以下环境
应用 redhat software_collections - -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 redhat_6 python * Up to
(excluding)
0:2.6.6-64.el6
运行在以下环境
系统 redhat_7 python * Up to
(excluding)
0:2.7.5-34.el7
运行在以下环境
系统 suse_12 python-devel * Up to
(excluding)
2.7.9-20
运行在以下环境
系统 ubuntu_12.04.5_lts python2.7 * Up to
(excluding)
2.7.3-0ubuntu3.8
运行在以下环境
系统 ubuntu_12.04_lts python2.7 * Up to
(excluding)
2.7.3-0ubuntu3.8
运行在以下环境
系统 ubuntu_14.04.6_lts python2.7 * Up to
(excluding)
2.7.6-8ubuntu0.2
运行在以下环境
系统 ubuntu_14.04_lts python2.7 * Up to
(excluding)
2.7.6-8ubuntu0.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-22 对路径名的限制不恰当(路径遍历)
阿里云安全产品覆盖情况