低危 Lua 'ldo.c'远程代码执行漏洞

CVE编号

CVE-2014-5461

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-09-05
漏洞描述
Lua是一个小巧的脚本语言。

Lua 'ldo.c'存在安全漏洞,允许远程攻击者利用漏洞执行任意代码。
解决建议
Lua 5.2.3已经修复该漏洞,建议用户下载更新:
http://www.lua.org/home.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 lua lua 5.1 -
运行在以下环境
应用 lua lua 5.1.1 -
运行在以下环境
应用 lua lua 5.1.2 -
运行在以下环境
应用 lua lua 5.1.3 -
运行在以下环境
应用 lua lua 5.1.4 -
运行在以下环境
应用 lua lua 5.1.5 -
运行在以下环境
应用 lua lua 5.2.0 -
运行在以下环境
应用 lua lua 5.2.1 -
运行在以下环境
应用 lua lua 5.2.2 -
运行在以下环境
系统 amazon linux_AMI lua * Up to
(excluding)
5.1.4-4.1.9.amzn1
运行在以下环境
系统 amazon_AMI lua * Up to
(excluding)
5.1.4-4.1.9.amzn1
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 debian debian_linux 7.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.1.5-7
运行在以下环境
系统 debian_6 lua * Up to
(excluding)
5.1.4-5+deb6u1
运行在以下环境
系统 debian_7 lua * Up to
(excluding)
5.1.5-4+deb7u1
运行在以下环境
系统 mageia mageia 3.0 -
运行在以下环境
系统 mageia mageia 4.0 -
运行在以下环境
系统 opensuse opensuse 12.3 -
运行在以下环境
系统 opensuse opensuse 13.1 -
运行在以下环境
系统 sles_12 liblua5_2 * Up to
(excluding)
5.2.2-4
运行在以下环境
系统 ubuntu_12.04_lts lua5.1 * Up to
(excluding)
5.1.4-12ubuntu1.1
运行在以下环境
系统 ubuntu_14.04 lua * Up to
(excluding)
5.1.5-5ubuntu0.1
运行在以下环境
系统 ubuntu_14.04_lts lua5.1 * Up to
(excluding)
5.1.5-5ubuntu0.1
运行在以下环境
系统 ubuntu_16.04 lua * Up to
(excluding)
5.1.5-5ubuntu1
运行在以下环境
系统 ubuntu_16.04_lts lua5.1 * Up to
(excluding)
5.1.5-5ubuntu1
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况