中危 Debian Exuberant Ctags 5.8 jscript.c 拒绝服务漏洞

CVE编号

CVE-2014-7204

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-10-08
漏洞描述
Exuberant Ctags是一个生成C语言对象的索引文件。
Exuberant Ctags 'jscript.c'存在安全漏洞,允许远程攻击者在大量公开源代码上运行ctags,消耗大量CPU和磁盘内存,导致拒绝服务。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://sourceforge.net/p/ctags/code/791/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 debian exuberant_ctags 5.8 -
运行在以下环境
系统 alpine_3.10 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_3.11 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_3.12 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_3.13 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_3.14 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_3.15 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_3.6 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_3.7 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_3.8 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_3.9 ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 alpine_edge ctags * Up to
(excluding)
5.8-r5
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 debian debian_linux 7.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1:5.9~svn20110310-8
运行在以下环境
系统 debian_6 ctags * Up to
(excluding)
1:5.8-3squeeze2
运行在以下环境
系统 debian_7 ctags * Up to
(excluding)
1:5.9~svn20110310-4+deb7u1
运行在以下环境
系统 mageia mageia 3.0 -
运行在以下环境
系统 mageia mageia 4.0 -
运行在以下环境
系统 sles_12 ctags * Up to
(excluding)
5.8-7
运行在以下环境
系统 sles_12_SP1 ctags * Up to
(excluding)
5.8-7.1
运行在以下环境
系统 suse_12_SP1 ctags * Up to
(excluding)
5.8-7.1
运行在以下环境
系统 ubuntu_12.04_lts exuberant-ctags * Up to
(excluding)
1:5.9~svn20110310-3ubuntu0.1
运行在以下环境
系统 ubuntu_14.04_lts exuberant-ctags * Up to
(excluding)
1:5.9~svn20110310-7ubuntu0.1
阿里云评分
6.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况