低危 netcf up to 0.2.6 Path Expression find_ifcfg_path 拒绝服务漏洞

CVE编号

CVE-2014-8119

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-12-30 11:29:00
漏洞描述
0.2.7之前的netcf中的find_ifcfg_path函数可能使攻击者能够通过涉及Augeas路径表达式的向量来导致拒绝服务(应用程序崩溃)。

解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://access.redhat.com/security/cve/cve-2014-8119
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netcf_project netcf * Up to
(including)
0.2.6
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
运行在以下环境
系统 fedoraproject fedora 20 -
运行在以下环境
系统 fedoraproject fedora 21 -
运行在以下环境
系统 fedoraproject fedora 22 -
运行在以下环境
系统 fedora_21 augeas * Up to
(excluding)
0.2.8-1.fc21
运行在以下环境
系统 fedora_21 libaugeas0 * Up to
(excluding)
0.2.8-1.fc21
运行在以下环境
系统 fedora_22 augeas * Up to
(excluding)
0.2.8-1.fc22
运行在以下环境
系统 fedora_22 libaugeas0 * Up to
(excluding)
0.2.8-1.fc22
运行在以下环境
系统 oracle linux_7 augeas * Up to
(excluding)
0.2.8-1.el7
运行在以下环境
系统 oracle linux_7 libaugeas0 * Up to
(excluding)
0.2.8-1.el7
运行在以下环境
系统 oracle_7 libaugeas0 * Up to
(excluding)
0.2.8-1.el7
运行在以下环境
系统 redhat enterprise_linux 6.0 -
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 redhat_6 netcf * Up to
(excluding)
0:0.2.4-3.el6
运行在以下环境
系统 redhat_7 netcf * Up to
(excluding)
0:0.2.8-1.el7
运行在以下环境
系统 sles_11_SP3 augeas * Up to
(excluding)
0.9.0-3.17.2
运行在以下环境
系统 sles_11_SP3 libaugeas0 * Up to
(excluding)
0.9.0-3.17.2
运行在以下环境
系统 sles_11_SP4 augeas * Up to
(excluding)
0.9.0-3.17.2
运行在以下环境
系统 sles_11_SP4 libaugeas0 * Up to
(excluding)
0.9.0-3.17.2
运行在以下环境
系统 sles_12 augeas * Up to
(excluding)
1.2.0-10
运行在以下环境
系统 sles_12 augeas * Up to
(excluding)
1.2.0-3.1
运行在以下环境
系统 sles_12 libaugeas0 * Up to
(excluding)
1.2.0-3.1
运行在以下环境
系统 suse_11_SP3 libaugeas0 * Up to
(excluding)
0.9.0-3.17.2
运行在以下环境
系统 suse_11_SP4 libaugeas0 * Up to
(excluding)
0.9.0-3.17.2
运行在以下环境
系统 suse_12 libaugeas0 * Up to
(excluding)
1.2.0-3.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况