中危 Mutt 'mutt_substrdup()'堆缓冲区溢出漏洞

CVE编号

CVE-2014-9116

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-12-03
漏洞描述
Mutt是一款小型的基于文本的MIME邮件客户端。

Mutt 'mutt_substrdup()'存在堆缓冲区溢出漏洞,允许攻击者利用漏洞在应用程序的上下文中执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://www.mutt.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mutt mutt 1.5.23 -
运行在以下环境
系统 debian debian_linux 7.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.5.23-2
运行在以下环境
系统 debian_6 mutt * Up to
(excluding)
1.5.20-9+squeeze4
运行在以下环境
系统 debian_7 mutt * Up to
(excluding)
1.5.21-6.2+deb7u3
运行在以下环境
系统 fedora_21 mutt * Up to
(excluding)
1.5.23-7.fc21
运行在以下环境
系统 mageia mageia 4.0 -
运行在以下环境
系统 opensuse_Leap_15.0 mutt * Up to
(excluding)
1.10.1-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_42.3 mutt * Up to
(excluding)
1.10.1-2.5.1
运行在以下环境
系统 sles_12 mutt * Up to
(excluding)
1.5.21-49
运行在以下环境
系统 sles_12_SP3 mutt * Up to
(excluding)
1.10.1-55.3.1
运行在以下环境
系统 suse linux_enterprise_desktop 12 -
运行在以下环境
系统 suse suse_linux_enterprise_server 12 -
运行在以下环境
系统 suse_12 mutt * Up to
(excluding)
1.5.21-49
运行在以下环境
系统 suse_12_SP3 mutt * Up to
(excluding)
1.10.1-55.3.1
运行在以下环境
系统 ubuntu_12.04.5_lts mutt * Up to
(excluding)
1.5.21-5ubuntu2.2
运行在以下环境
系统 ubuntu_12.04_lts mutt * Up to
(excluding)
1.5.21-5ubuntu2.2
运行在以下环境
系统 ubuntu_14.04.6_lts mutt * Up to
(excluding)
1.5.21-6.4ubuntu2.1
运行在以下环境
系统 ubuntu_14.04_lts mutt * Up to
(excluding)
1.5.21-6.4ubuntu2.1
阿里云评分
6.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况