中危 Exiv riffvideo.cpp缓冲区溢出漏洞

CVE编号

CVE-2014-9449

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-01-03
漏洞描述
Exiv2是一个用来提取图片中的EXIF、LPTC和XMP元数据信息的C++类库。

Exiv2 riffvideo.cpp中的RiffVideo::infoTagsHandler函数存在缓冲区溢出漏洞,允许攻击者构建包含超长IKEY INFO标签值的AVI文件,诱使用户解析,可使应用程序崩溃。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://dev.exiv2.org/projects/exiv2/repository/diff?rev=3264&rev_to=3263
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 exiv2 exiv2 0.24 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0.24-4.1
运行在以下环境
系统 fedora_21 exiv2 * Up to
(excluding)
0.24-4.fc21
运行在以下环境
系统 fedora_21 exiv2-debuginfo * Up to
(excluding)
0.24-4.fc21
运行在以下环境
系统 fedora_21 exiv2-devel * Up to
(excluding)
0.24-4.fc21
运行在以下环境
系统 fedora_21 exiv2-doc * Up to
(excluding)
0.24-4.fc21
运行在以下环境
系统 fedora_21 exiv2-libs * Up to
(excluding)
0.24-4.fc21
阿里云评分
6.5
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况