中危 Mercurial sshpeer '_validaterepo'函数任意命令执行漏洞

CVE编号

CVE-2014-9462

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-04-01
漏洞描述
Mercurial是软件开发者Matt Mackall所研发的一套使用Python语言编写的跨平台的分布式版本控制软件。该软件支持同时处理纯文本和二进制文件等。

Mercurial 3.2.4之前版本的sshpeer中的‘_validaterepo’函数存在安全漏洞。远程攻击者可借助clone命令中特制的资源库名称利用该漏洞执行任意命令。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
http://mercurial.selenic.com/wiki/WhatsNew#Mercurial_3.2.4_.282015-01-01.29
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mercurial mercurial * Up to
(including)
3.2.3
运行在以下环境
系统 debian DPKG * Up to
(excluding)
3.4-1
运行在以下环境
系统 debian_6 mercurial * Up to
(excluding)
1.6.4-1+deb6u1
运行在以下环境
系统 debian_7 mercurial * Up to
(excluding)
2.2.2-4+deb7u1
运行在以下环境
系统 debian_8 mercurial * Up to
(excluding)
3.1.2-2+deb8u1
运行在以下环境
系统 opensuse opensuse 13.1 -
运行在以下环境
系统 opensuse opensuse 13.2 -
运行在以下环境
系统 ubuntu_12.04.5_lts mercurial * Up to
(excluding)
2.0.2-1ubuntu1.2
运行在以下环境
系统 ubuntu_12.04_lts mercurial * Up to
(excluding)
2.0.2-1ubuntu1.2
运行在以下环境
系统 ubuntu_14.04 mercurial * Up to
(excluding)
2.8.2-1ubuntu1.3
运行在以下环境
系统 ubuntu_14.04.6_lts mercurial * Up to
(excluding)
2.8.2-1ubuntu1.3
运行在以下环境
系统 ubuntu_14.04_lts mercurial * Up to
(excluding)
2.8.2-1ubuntu1.3
阿里云评分
6.9
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况