低危 PHP 'locale_get_display_name()'栈缓冲区溢出漏洞

CVE编号

CVE-2014-9912

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-01-05 09:59:00
漏洞描述
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言支持多重语法、支持多数据库及操作系统和支持C、C++进行程序扩展等。
PHP 'locale_get_display_name()'函数存在栈缓冲区溢出漏洞。攻击者可利用该漏洞执行任意代码,造成拒绝服务。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
http://www.php.net/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * Up to
(including)
5.3.28
运行在以下环境
应用 php php 5.4.0 -
运行在以下环境
应用 php php 5.4.1 -
运行在以下环境
应用 php php 5.4.2 -
运行在以下环境
应用 php php 5.4.3 -
运行在以下环境
应用 php php 5.4.4 -
运行在以下环境
应用 php php 5.4.5 -
运行在以下环境
应用 php php 5.4.6 -
运行在以下环境
应用 php php 5.4.7 -
运行在以下环境
应用 php php 5.4.8 -
运行在以下环境
应用 php php 5.4.9 -
运行在以下环境
应用 php php 5.4.10 -
运行在以下环境
应用 php php 5.4.11 -
运行在以下环境
应用 php php 5.4.12 -
运行在以下环境
应用 php php 5.4.12 rc1 -
运行在以下环境
应用 php php 5.4.12 rc2 -
运行在以下环境
应用 php php 5.4.13 -
运行在以下环境
应用 php php 5.4.13 rc1 -
运行在以下环境
应用 php php 5.4.14 -
运行在以下环境
应用 php php 5.4.14 rc1 -
运行在以下环境
应用 php php 5.4.15 -
运行在以下环境
应用 php php 5.4.15 rc1 -
运行在以下环境
应用 php php 5.4.16 rc1 -
运行在以下环境
应用 php php 5.4.17 -
运行在以下环境
应用 php php 5.4.18 -
运行在以下环境
应用 php php 5.4.19 -
运行在以下环境
应用 php php 5.4.20 -
运行在以下环境
应用 php php 5.4.21 -
运行在以下环境
应用 php php 5.4.22 -
运行在以下环境
应用 php php 5.4.23 -
运行在以下环境
应用 php php 5.4.24 -
运行在以下环境
应用 php php 5.4.25 -
运行在以下环境
应用 php php 5.4.26 -
运行在以下环境
应用 php php 5.4.27 -
运行在以下环境
应用 php php 5.4.28 -
运行在以下环境
应用 php php 5.4.29 -
运行在以下环境
应用 php php 5.5.0 -
运行在以下环境
应用 php php 5.5.0 alpha1 -
运行在以下环境
应用 php php 5.5.0 alpha2 -
运行在以下环境
应用 php php 5.5.0 alpha3 -
运行在以下环境
应用 php php 5.5.0 alpha4 -
运行在以下环境
应用 php php 5.5.0 alpha5 -
运行在以下环境
应用 php php 5.5.0 alpha6 -
运行在以下环境
应用 php php 5.5.0 beta1 -
运行在以下环境
应用 php php 5.5.0 beta2 -
运行在以下环境
应用 php php 5.5.0 beta3 -
运行在以下环境
应用 php php 5.5.0 beta4 -
运行在以下环境
应用 php php 5.5.0 rc1 -
运行在以下环境
应用 php php 5.5.0 rc2 -
运行在以下环境
应用 php php 5.5.1 -
运行在以下环境
应用 php php 5.5.2 -
运行在以下环境
应用 php php 5.5.3 -
运行在以下环境
应用 php php 5.5.4 -
运行在以下环境
应用 php php 5.5.5 -
运行在以下环境
应用 php php 5.5.6 -
运行在以下环境
应用 php php 5.5.7 -
运行在以下环境
应用 php php 5.5.8 -
运行在以下环境
应用 php php 5.5.9 -
运行在以下环境
应用 php php 5.5.10 -
运行在以下环境
应用 php php 5.5.11 -
运行在以下环境
应用 php php 5.5.12 -
运行在以下环境
应用 php php 5.5.13 -
2
运行在以下环境
系统 suse_11_SP4 php53-fileinfo * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-fastcgi * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-gd * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-gettext * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-odbc * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-mysql * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-openssl * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-pdo * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-xmlrpc * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-xmlreader * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-shmop * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-mcrypt * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-mbstring * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-zlib * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-soap * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-sysvmsg * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-dba * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 apache2-mod_php53 * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-intl * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-pspell * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-curl * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-bz2 * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-sysvshm * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-exif * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-sysvsem * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-dom * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-suhosin * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-pcntl * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-wddx * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-tokenizer * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-ctype * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-iconv * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-pgsql * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53 * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-bcmath * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-gmp * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-ftp * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-zip * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-calendar * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-pear * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-ldap * Up to
(excluding)
5.3.17-94.1
运行在以下环境
系统 suse_11_SP4 php53-xmlwr * Up to
(excluding)
5.3.17-94.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况