Pivotal Software Spring Framework Java SockJS客户端存在未明漏洞

CVE编号

CVE-2015-0201

利用情况

暂无

补丁情况

N/A

披露时间

2015-03-11
漏洞描述
Pivotal Software Spring Framework是美国Pivotal Software公司的一套开源的Java、Java EE应用程序框架。该框架可帮助开发人员构建高质量的应用。

Pivotal Software Spring Framework 4.1.5之前4.1.x版本的Java SockJS客户端中存在安全漏洞,该漏洞源于程序生成可预测的会话ID。远程攻击者可利用该漏洞向其他会话发送消息。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://pivotal.io/security/cve-2015-0201
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 pivotal_software spring_framework 4.1.0 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.1 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.2 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.3 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.4 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
0
CVSS3评分
5.0
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    N/A
  • 用户交互
  • 可用性
  • 保密性
    部分地
  • 完整性
CWE-ID 漏洞类型
阿里云安全产品覆盖情况