低危 Google Chrome Expat整数溢出漏洞

CVE编号

CVE-2015-1283

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-07-23
漏洞描述
Google Chrome是美国谷歌(Google)公司开发的一款Web浏览器。Expat是美国软件开发者吉姆-克拉克所研发的一个基于C语言的XML解析器库,它采用了一个面向流的解析器。

Google Chrome 44.0.2403.89之前版本中使用的Expat 2.1.0及之前版本中的‘XML_GetBuffer’函数存在整数溢出漏洞。远程攻击者可借助特制的XML数据利用该漏洞造成拒绝服务(基于堆的缓冲区溢出)。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
http://googlechromereleases.blogspot.com/2015/07/stable-channel-update_21.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 google chrome * Up to
(including)
43.0.2357.134
运行在以下环境
应用 libexpat expat * Up to
(including)
2.1.0
运行在以下环境
系统 debian DPKG * Up to
(excluding)
2.1.0-7
运行在以下环境
系统 debian_6 expat * Up to
(excluding)
2.0.1-7+squeeze2
运行在以下环境
系统 debian_7 expat * Up to
(excluding)
2.1.0-1+deb7u2
运行在以下环境
系统 debian_8 expat * Up to
(excluding)
48.0.2564.116-1~deb8u1
运行在以下环境
系统 opensuse_13.1 expat * Up to
(excluding)
44.0.2403.89-93.1
运行在以下环境
系统 opensuse_13.2 expat * Up to
(excluding)
44.0.2403.89-38.1
运行在以下环境
系统 opensuse_Leap_42.1 expat * Up to
(excluding)
2.1.0-17.1
运行在以下环境
系统 redhat_6 chromium-browser * Up to
(excluding)
0:44.0.2403.89-1.el6
运行在以下环境
系统 suse_11_SP4 expat * Up to
(excluding)
2.0.1-88.38.1
运行在以下环境
系统 suse_12 expat * Up to
(excluding)
2.1.0-17.1
运行在以下环境
系统 suse_12_SP1 expat * Up to
(excluding)
2.1.0-17.1
运行在以下环境
系统 ubuntu_12.04.5_lts expat * Up to
(excluding)
2.0.1-7.2ubuntu1.2
运行在以下环境
系统 ubuntu_14.04 expat * Up to
(excluding)
2.1.0-4ubuntu1.1
运行在以下环境
系统 ubuntu_14.04.6_lts chromium-browser * Up to
(excluding)
44.0.2403.89-0ubuntu0.14.04.1.1095
运行在以下环境
系统 ubuntu_16.04 expat * Up to
(excluding)
44.0.2403.89-0ubuntu1.1195
运行在以下环境
系统 ubuntu_16.04.7_lts chromium-browser * Up to
(excluding)
44.0.2403.89-0ubuntu1.1195
运行在以下环境
系统 ubuntu_18.04 expat * Up to
(excluding)
44.0.2403.89-0ubuntu1.1195
运行在以下环境
系统 ubuntu_18.04.5_lts chromium-browser * Up to
(excluding)
44.0.2403.89-0ubuntu1.1195
运行在以下环境
系统 ubuntu_18.10 chromium-browser * Up to
(excluding)
44.0.2403.89-0ubuntu1.1195
运行在以下环境
系统 ubuntu_20.04 expat * Up to
(excluding)
44.0.2403.89-0ubuntu1.1195
运行在以下环境
系统 ubuntu_21.04 expat * Up to
(excluding)
44.0.2403.89-0ubuntu1.1195
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    -
CWE-ID 漏洞类型
CWE-189 数值错误
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况