中危 e2fsprogs本地缓冲区溢出漏洞

CVE编号

CVE-2015-1572

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-02-25
漏洞描述
e2fsprogs(Ext2 Filesystem Utilities)是针对EXT2文件系统的一套磁盘工具。

e2fsprogs存在本地缓冲区溢出漏洞,攻击者可利用此漏洞在受影响的应用程序中执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:http://e2fsprogs.sourceforge.net/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 e2fsprogs_project e2fsprogs * Up to
(including)
1.42.11
运行在以下环境
系统 debian_6 e2fsprogs * Up to
(excluding)
1.41.12-4+deb6u2
运行在以下环境
系统 debian_7 e2fsprogs * Up to
(excluding)
1.42.5-1.1+deb7u1
运行在以下环境
系统 fedora_21 e2fsprogs * Up to
(excluding)
1.42.12-3.fc21
运行在以下环境
系统 opensuse_13.2 e2fsprogs * Up to
(excluding)
1.42.12-7.1
运行在以下环境
系统 opensuse_Leap_15.0 e2fsprogs * Up to
(excluding)
1.43.8-lp150.3.3.1
运行在以下环境
系统 suse_11_SP3 e2fsprogs * Up to
(excluding)
1.41.9-2.10.11.1
运行在以下环境
系统 suse_12 e2fsprogs * Up to
(excluding)
1.42.11-7.1
运行在以下环境
系统 ubuntu_14.04 e2fsprogs * Up to
(excluding)
1.42.9-3ubuntu1.2
阿里云评分
6.7
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况