低危 Apache OpenOffice up to 4.1.1 HWP Filter Crash 拒绝服务漏洞

CVE编号

CVE-2015-1774

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-04-29
漏洞描述
LibreOffice是可在各种平台上执行的、与其他主要办公室软体兼容的套件。

LibreOffice 4.3.7之前的版本、4.4.2之前的4.4.x版本及Apache OpenOffice 4.1.2之前的版本存在拒绝服务漏洞,允许远程攻击者通过精心编制的HWP文件触发器越界写,导致拒绝服务或可能执行任意代码。
解决建议
用户可参考如下厂商提供的安全公告获取补丁以修复该漏洞:
http://www.openoffice.org/security/cves/CVE-2015-1774.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache openoffice * Up to
(including)
4.1.1
运行在以下环境
应用 libreoffice libreoffice * Up to
(including)
4.3.6
运行在以下环境
应用 libreoffice libreoffice 4.4.0 -
运行在以下环境
应用 libreoffice libreoffice 4.4.1 -
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.10 -
运行在以下环境
系统 debian debian_linux 7.0 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1:4.4.2-1
运行在以下环境
系统 debian_7 libreoffice * Up to
(excluding)
1:3.5.4+dfsg2-0+deb7u4
运行在以下环境
系统 debian_8 libreoffice * Up to
(excluding)
1:4.3.3-2+deb8u1
运行在以下环境
系统 fedoraproject fedora 21 -
运行在以下环境
系统 fedora_21 libreoffice * Up to
(excluding)
4.3.7.2-3.fc21
运行在以下环境
系统 opensuse_13.2 libreoffice * Up to
(excluding)
4.3.7.2-18.1
运行在以下环境
系统 oracle linux_6 libreoffice * Up to
(excluding)
4.2.8.2-11.0.1.el6
运行在以下环境
系统 oracle_6 libreoffice * Up to
(excluding)
4.2.8.2-11.0.1.el6
运行在以下环境
系统 redhat enterprise_linux_desktop 6.0 -
运行在以下环境
系统 redhat enterprise_linux_server 6.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 6.0 -
运行在以下环境
系统 redhat_6 autocorr-af * Up to
(excluding)
1:4.2.8.2-11.el6
运行在以下环境
系统 redhat_7 libwpd * Up to
(excluding)
0:0.10.0-1.el7
运行在以下环境
系统 sles_12 apache-commons-logging * Up to
(excluding)
1.1.3-7
运行在以下环境
系统 sles_12 libreoffice * Up to
(excluding)
1.3.1-3.1
运行在以下环境
系统 suse_12 libreoffice * Up to
(excluding)
3-1.3.1-3.1
运行在以下环境
系统 ubuntu_12.04.5_lts libreoffice * Up to
(excluding)
1:3.5.7-0ubuntu8
运行在以下环境
系统 ubuntu_12.04_lts libreoffice * Up to
(excluding)
1:3.5.7-0ubuntu8
运行在以下环境
系统 ubuntu_14.04.6_lts libreoffice * Up to
(excluding)
1:4.2.8-0ubuntu2
运行在以下环境
系统 ubuntu_14.04_lts libreoffice * Up to
(excluding)
1:4.2.8-0ubuntu2
阿里云评分
2.5
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    N/A
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-787 跨界内存写
阿里云安全产品覆盖情况