低危 Qt存在多个缓冲区溢出漏洞

CVE编号

CVE-2015-1859

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-05-13
漏洞描述
Qt是一个跨平台应用程序框架。

Qt 4.8.7之前的版本,5.4.2之前的5.x版本存在多个缓冲区溢出漏洞,允许远程攻击者通过精心编制的ICO图像导致拒绝服务并可能执行任意代码。
解决建议
用户可参考如下厂商提供的安全公告获取补丁以修复该漏洞:
http://lists.fedoraproject.org/pipermail/package-announce/2015-April/156727.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 digia qt * Up to
(including)
4.8.6
运行在以下环境
应用 digia qt 5.0.0 -
运行在以下环境
应用 digia qt 5.0.1 -
运行在以下环境
应用 digia qt 5.0.2 -
运行在以下环境
应用 digia qt 5.1.0 -
运行在以下环境
应用 digia qt 5.2.0 -
运行在以下环境
应用 digia qt 5.2.1 -
运行在以下环境
应用 digia qt 5.3.0 -
运行在以下环境
应用 digia qt 5.4.1 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
4:4.8.6+git155-g716fbae+dfsg-2
运行在以下环境
系统 debian_10 qt4-x11 * Up to
(excluding)
4:4.8.6+git155-g716fbae+dfsg-2
运行在以下环境
系统 debian_11 qtbase-opensource-src * Up to
(excluding)
5.3.2+dfsg-5
运行在以下环境
系统 debian_12 qtbase-opensource-src * Up to
(excluding)
5.3.2+dfsg-5
运行在以下环境
系统 debian_6 qt4-x11 * Up to
(excluding)
4:4.6.3-4+squeeze3
运行在以下环境
系统 debian_8 qt4-x11 * Up to
(excluding)
4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
运行在以下环境
系统 fedoraproject fedora 20 -
运行在以下环境
系统 fedoraproject fedora 21 -
运行在以下环境
系统 fedoraproject fedora 22 -
运行在以下环境
系统 fedora_21 qt3-ODBC * Up to
(excluding)
5.4.1-2.fc21
运行在以下环境
系统 fedora_22 qt3-ODBC * Up to
(excluding)
5.4.1-9.fc22
运行在以下环境
系统 fedora_EPEL_7 qt5-qtbase-devel * Up to
(excluding)
4.8.6-8.el7
运行在以下环境
系统 suse_11_SP3 libqt4-x11-32bit * Up to
(excluding)
4.6.3-5.34.2
运行在以下环境
系统 suse_12 libQt5Core5 * Up to
(excluding)
4.8.6-4.2
运行在以下环境
系统 ubuntu_12.04.5_lts qt4-x11 * Up to
(excluding)
4:4.8.1-0ubuntu4.9
运行在以下环境
系统 ubuntu_14.04 qt4-x11 * Up to
(excluding)
5.2.1+dfsg-1ubuntu14.3
运行在以下环境
系统 ubuntu_14.04.6_lts qt4-x11 * Up to
(excluding)
4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
阿里云评分
2.5
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    N/A
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况