低危 cURL及libcurl信息泄露漏洞

CVE编号

CVE-2015-3236

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-06-23
漏洞描述
cURL/libcURL是命令行传输文件工具,支持FTP、FTPS、HTTP、HTTPS、GOPHER、TELNET、DICT、FILE和LDAP。

cURL及libcurl在重用curl_easy_reset连接句柄向同一个主机名发送请求时,会附带上一个连接的HTTP Basic身份验证凭证,可导致敏感信息泄露。
解决建议
用户可参考如下厂商提供的安全公告获取补丁以修复该漏洞:
http://curl.haxx.se/CVE-2015-3236.patch
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl 7.40.0 -
运行在以下环境
应用 haxx curl 7.41.0 -
运行在以下环境
应用 haxx curl 7.42.0 -
运行在以下环境
应用 haxx curl 7.42.1 -
运行在以下环境
应用 haxx libcurl 7.40.0 -
运行在以下环境
应用 haxx libcurl 7.41.0 -
运行在以下环境
应用 haxx libcurl 7.42.0 -
运行在以下环境
应用 haxx libcurl 7.42.1 -
运行在以下环境
系统 amazon_AMI curl * Up to
(excluding)
7.40.0-3.51.amzn1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
7.43.0-1
运行在以下环境
系统 fedora_22 curl * Up to
(excluding)
7.40.0-5.fc22
运行在以下环境
系统 suse_12 curl * Up to
(excluding)
7.60.0-2
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况