中危 Apple Mac OS X 至 10.10.4 Libc 内存破坏漏洞

CVE编号

CVE-2015-3796

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2015-08-17 13:00:00
漏洞描述
Apple iOS是一款运行在苹果iPhone和iPod touch设备上的最新的操作系统。
Apple iOS Libc TRE存在内存破坏漏洞,允许攻击者利用漏洞使应用程序处理特殊的规则表达式,执行任意代码。
解决建议
用户可参考如下厂商提供的安全公告获取补丁以修复该漏洞:
https://support.apple.com/en-us/HT205030
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 fedora_EPEL_6 tre-debuginfo * Up to
(excluding)
0.7.6-3.el6
运行在以下环境
系统 fedora_EPEL_6 python-tre * Up to
(excluding)
0.7.6-3.el6
运行在以下环境
系统 fedora_EPEL_6 tre-devel * Up to
(excluding)
0.7.6-3.el6
运行在以下环境
系统 fedora_EPEL_6 agrep * Up to
(excluding)
0.7.6-3.el6
运行在以下环境
系统 fedora_EPEL_6 tre * Up to
(excluding)
0.7.6-3.el6
2
运行在以下环境
系统 apple iphone_os * Up to
(including)
8.4
3
运行在以下环境
系统 apple mac_os_x * Up to
(including)
10.10.4
4
运行在以下环境
系统 fedora_23 tre-debuginfo * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc23
运行在以下环境
系统 fedora_23 python-tre * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc23
运行在以下环境
系统 fedora_23 tre-devel * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc23
运行在以下环境
系统 fedora_23 agrep * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc23
运行在以下环境
系统 fedora_23 tre * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc23
5
运行在以下环境
系统 fedora_25 tre-debuginfo * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc25
运行在以下环境
系统 fedora_25 python-tre * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc25
运行在以下环境
系统 fedora_25 tre-devel * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc25
运行在以下环境
系统 fedora_25 agrep * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc25
运行在以下环境
系统 fedora_25 tre * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc25
6
运行在以下环境
系统 fedora_24 tre-debuginfo * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc24
运行在以下环境
系统 fedora_24 python-tre * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc24
运行在以下环境
系统 fedora_24 tre-devel * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc24
运行在以下环境
系统 fedora_24 agrep * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc24
运行在以下环境
系统 fedora_24 tre * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.fc24
7
运行在以下环境
系统 fedora_EPEL_6 tre-debuginfo * Up to
(excluding)
0.7.6-3.el6
8
运行在以下环境
系统 fedora_EPEL_7 tre-debuginfo * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.el7
9
运行在以下环境
系统 fedora_EPEL_7 tre-debuginfo * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.el7
运行在以下环境
系统 fedora_EPEL_7 python-tre * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.el7
运行在以下环境
系统 fedora_EPEL_7 tre-devel * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.el7
运行在以下环境
系统 fedora_EPEL_7 agrep * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.el7
运行在以下环境
系统 fedora_EPEL_7 tre * Up to
(excluding)
0.8.0-18.20140228gitc2f5d13.el7
阿里云评分
4.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况