中危 Ansible安全绕过漏洞

CVE编号

CVE-2015-3908

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-08-13 03:59:00
漏洞描述
Ansible是新出现的运维工具是基于Python研发的糅合了众多老牌运维工具的优点实现了批量操作系统配置、批量程序的部署、批量运行命令等功能。
Ansible 1.9.2之前版本中存在安全绕过漏洞,攻击者可利用该漏洞实施中间人攻击,或冒充可信服务器。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://releases.ansible.com/ansible/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible * Up to
(including)
1.9.1
2
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
1.9.2-1.el6
3
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
1.9.2-1.el7
4
运行在以下环境
系统 fedora_21 ansible * Up to
(excluding)
1.9.2-1.fc21
5
运行在以下环境
系统 fedora_EPEL_6 ansible * Up to
(excluding)
1.9.2-1.el6
6
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
1.9.2-1.el7
7
运行在以下环境
系统 fedora_22 ansible * Up to
(excluding)
1.9.2-1.fc22
8
运行在以下环境
系统 debian_8 ansible * Up to
(excluding)
1.7.2+dfsg-2+deb8u2
9
运行在以下环境
系统 opensuse_13.2 ansible * Up to
(excluding)
1.7.1-2.8.1
阿里云评分
5.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-345 对数据真实性的验证不充分
阿里云安全产品覆盖情况