Puppet Enterprise反向代理漏洞

CVE编号

CVE-2015-4100

利用情况

暂无

补丁情况

N/A

披露时间

2017-12-22
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是一个企业版。

Puppet Enterprise中存在安全漏洞。远程攻击者可利用该漏洞废除其他节点的证书,造成拒绝服务或泄露敏感数据。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://puppet.com/security/cve/CVE-2015-4100
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * From
(including)
3.7.0
Up to
(including)
3.7.2
运行在以下环境
应用 puppet puppet 3.8.0 -
CVSS3评分
6.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况