中危 Xen GNTTABOP_swap_grant_ref()版本检查拒绝服务漏洞

CVE编号

CVE-2015-4163

利用情况

暂无

补丁情况

官方补丁

披露时间

2015-06-16
漏洞描述
Xen是一款用于Linux内核的一种虚拟化技术,允许同时运行多个操作系统。

Xen GNTTABOP_swap_grant_ref()存在安全漏洞,由于程序调用未能正确检查表授权操作的版本,允许本地用户利用漏洞触发空指针引用,使目标HOST崩溃。
解决建议
用户可参考如下厂商提供的安全公告获取补丁以修复该漏洞:
http://xenbits.xen.org/xsa/advisory-134.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 debian DPKG * Up to
(excluding)
4.6.0-1
运行在以下环境
系统 debian_10 xen * Up to
(excluding)
4.6.0-1
运行在以下环境
系统 debian_11 xen * Up to
(excluding)
4.6.0-1
运行在以下环境
系统 debian_12 xen * Up to
(excluding)
4.6.0-1
运行在以下环境
系统 debian_7 xen * Up to
(excluding)
4.1.4-3+deb7u8
运行在以下环境
系统 debian_8 xen * Up to
(excluding)
4.4.1-9+deb8u3
运行在以下环境
系统 fedora_21 xen-hypervisor * Up to
(excluding)
4.4.2-6.fc21
运行在以下环境
系统 fedora_22 xen-hypervisor * Up to
(excluding)
4.5.0-11.fc22
运行在以下环境
系统 opensuse_13.1 xen-libs-debuginfo-32bit * Up to
(excluding)
4.3.4_05-47.1
运行在以下环境
系统 opensuse_13.2 xen-tools-domU * Up to
(excluding)
4.4.2_06-23.1
运行在以下环境
系统 suse_11_SP3 xen * Up to
(excluding)
4.2.5_08-0.9.1
运行在以下环境
系统 suse_12 xen * Up to
(excluding)
4.4.2_06-21.1
运行在以下环境
系统 ubuntu_12.04.5_lts xen * Up to
(excluding)
4.1.6.1-0ubuntu0.12.04.6
运行在以下环境
系统 ubuntu_14.04 xen * Up to
(excluding)
4.4.2-0ubuntu0.14.04.2
运行在以下环境
系统 ubuntu_14.04.6_lts xen * Up to
(excluding)
4.4.2-0ubuntu0.14.04.2
运行在以下环境
系统 xen xen 4.2.0 -
运行在以下环境
系统 xen xen 4.2.1 -
运行在以下环境
系统 xen xen 4.2.2 -
运行在以下环境
系统 xen xen 4.2.3 -
运行在以下环境
系统 xen xen 4.3.0 -
运行在以下环境
系统 xen xen 4.3.1 -
运行在以下环境
系统 xen xen 4.3.4 -
运行在以下环境
系统 xen xen 4.4.0 -
运行在以下环境
系统 xen xen 4.4.1 -
运行在以下环境
系统 xen xen 4.5.0 -
阿里云评分
6.3
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况