低危 PHP SOAP访问远程内存破坏漏洞

CVE编号

CVE-2015-4599

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-05-16
漏洞描述
PHP是一款通用脚本语言。

PHP多种SOAP访问中使用的unserialize()函数存在安全漏洞,允许远程攻击者利用漏洞提交特殊请求获取PHP应用内存信息或崩溃。
解决建议
用户可参考如下厂商提供的安全公告获取补丁以修复该漏洞:
http://git.php.net/?p=php-src.git;a=commitdiff;h=0c136a2abd49298b66acb0cad504f0f972f5bfe8
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * Up to
(including)
5.4.39
运行在以下环境
应用 php php 5.5.0 -
运行在以下环境
应用 php php 5.5.1 -
运行在以下环境
应用 php php 5.5.10 -
运行在以下环境
应用 php php 5.5.11 -
运行在以下环境
应用 php php 5.5.12 -
运行在以下环境
应用 php php 5.5.13 -
运行在以下环境
应用 php php 5.5.14 -
运行在以下环境
应用 php php 5.5.15 -
运行在以下环境
应用 php php 5.5.16 -
运行在以下环境
应用 php php 5.5.17 -
运行在以下环境
应用 php php 5.5.18 -
运行在以下环境
应用 php php 5.5.19 -
运行在以下环境
应用 php php 5.5.2 -
运行在以下环境
应用 php php 5.5.20 -
运行在以下环境
应用 php php 5.5.21 -
运行在以下环境
应用 php php 5.5.22 -
运行在以下环境
应用 php php 5.5.23 -
运行在以下环境
应用 php php 5.5.3 -
运行在以下环境
应用 php php 5.5.4 -
运行在以下环境
应用 php php 5.5.5 -
运行在以下环境
应用 php php 5.5.6 -
运行在以下环境
应用 php php 5.5.7 -
运行在以下环境
应用 php php 5.5.8 -
运行在以下环境
应用 php php 5.5.9 -
运行在以下环境
应用 php php 5.6.0 -
运行在以下环境
应用 php php 5.6.1 -
运行在以下环境
应用 php php 5.6.2 -
运行在以下环境
应用 php php 5.6.3 -
运行在以下环境
应用 php php 5.6.4 -
运行在以下环境
应用 php php 5.6.5 -
运行在以下环境
应用 php php 5.6.6 -
运行在以下环境
应用 php php 5.6.7 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.9+dfsg-0+deb8u1
运行在以下环境
系统 redhat_6 php * Up to
(excluding)
0:5.3.3-46.el6_6
运行在以下环境
系统 redhat_7 php * Up to
(excluding)
0:5.4.16-36.el7_1
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-30
运行在以下环境
系统 ubuntu_12.04_lts php5 * Up to
(excluding)
5.3.10-1ubuntu3.19
运行在以下环境
系统 ubuntu_14.04_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.11
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况