低危 PHP 5.4.41/5.5.25/5.6.9 php_pgsql_meta_data 拒绝服务漏洞

CVE编号

CVE-2015-4644

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-05-16
漏洞描述
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。PostgreSQL(又名pgsql)是其中的一个对象关系型数据库管理系统扩展组件。
PHP的PostgreSQL扩展中的pgsql.c文件中的‘php_pgsql_meta_data’函数存在安全漏洞,远程攻击者可借助特制的名称利用该漏洞造成拒绝服务(空指针逆向引用和应用程序崩溃)。以下版本受到影响:PHP 5.4.42之前版本,5.5.26之前5.5.x版本,5.6.10之前5.6.x版本。(注:该漏洞源于 CVE-2015-1352补丁的不完全修复)
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
https://bugs.php.net/bug.php?id=69667
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * Up to
(including)
5.4.41
运行在以下环境
应用 php php 5.5.0 -
运行在以下环境
应用 php php 5.5.1 -
运行在以下环境
应用 php php 5.5.10 -
运行在以下环境
应用 php php 5.5.11 -
运行在以下环境
应用 php php 5.5.12 -
运行在以下环境
应用 php php 5.5.13 -
运行在以下环境
应用 php php 5.5.14 -
运行在以下环境
应用 php php 5.5.15 -
运行在以下环境
应用 php php 5.5.16 -
运行在以下环境
应用 php php 5.5.17 -
运行在以下环境
应用 php php 5.5.18 -
运行在以下环境
应用 php php 5.5.19 -
运行在以下环境
应用 php php 5.5.2 -
运行在以下环境
应用 php php 5.5.20 -
运行在以下环境
应用 php php 5.5.21 -
运行在以下环境
应用 php php 5.5.22 -
运行在以下环境
应用 php php 5.5.23 -
运行在以下环境
应用 php php 5.5.24 -
运行在以下环境
应用 php php 5.5.25 -
运行在以下环境
应用 php php 5.5.3 -
运行在以下环境
应用 php php 5.5.4 -
运行在以下环境
应用 php php 5.5.5 -
运行在以下环境
应用 php php 5.5.6 -
运行在以下环境
应用 php php 5.5.7 -
运行在以下环境
应用 php php 5.5.8 -
运行在以下环境
应用 php php 5.5.9 -
运行在以下环境
应用 php php 5.6.0 -
运行在以下环境
应用 php php 5.6.1 -
运行在以下环境
应用 php php 5.6.2 -
运行在以下环境
应用 php php 5.6.3 -
运行在以下环境
应用 php php 5.6.4 -
运行在以下环境
应用 php php 5.6.5 -
运行在以下环境
应用 php php 5.6.6 -
运行在以下环境
应用 php php 5.6.7 -
运行在以下环境
应用 php php 5.6.8 -
运行在以下环境
应用 php php 5.6.9 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
5.6.12+dfsg-0+deb8u1
运行在以下环境
系统 redhat enterprise_linux 6.0 -
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 sles_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-30
运行在以下环境
系统 ubuntu_12.04_lts php5 * Up to
(excluding)
5.3.10-1ubuntu3.19
运行在以下环境
系统 ubuntu_14.04_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.11
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况