低危 Zend Framework 1.12.13/2.4.2 Zend_XmlRpc_Server 拒绝服务漏洞

CVE编号

CVE-2015-5161

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2015-08-26
漏洞描述
Zend Framework(ZF)是美国Zend公司开发的一套开源的PHP5开发框架,它主要用于开发Web程序和服务。

ZF 2.4.2及之前版本和1.12.13及之前版本中存在XML外部实体注入漏洞。攻击者可利用该漏洞获取敏感信息的访问权限。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
http://framework.zend.com/security/advisory/ZF2015-06
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 zend zend_framework 1.0.0 -
运行在以下环境
应用 zend zend_framework 1.0.1 -
运行在以下环境
应用 zend zend_framework 1.0.2 -
运行在以下环境
应用 zend zend_framework 1.0.3 -
运行在以下环境
应用 zend zend_framework 1.0.4 -
运行在以下环境
应用 zend zend_framework 1.10.0 -
运行在以下环境
应用 zend zend_framework 1.10.1 -
运行在以下环境
应用 zend zend_framework 1.10.2 -
运行在以下环境
应用 zend zend_framework 1.10.3 -
运行在以下环境
应用 zend zend_framework 1.10.4 -
运行在以下环境
应用 zend zend_framework 1.10.5 -
运行在以下环境
应用 zend zend_framework 1.10.6 -
运行在以下环境
应用 zend zend_framework 1.10.7 -
运行在以下环境
应用 zend zend_framework 1.10.8 -
运行在以下环境
应用 zend zend_framework 1.10.9 -
运行在以下环境
应用 zend zend_framework 1.11.0 -
运行在以下环境
应用 zend zend_framework 1.11.1 -
运行在以下环境
应用 zend zend_framework 1.11.10 -
运行在以下环境
应用 zend zend_framework 1.11.11 -
运行在以下环境
应用 zend zend_framework 1.11.12 -
运行在以下环境
应用 zend zend_framework 1.11.13 -
运行在以下环境
应用 zend zend_framework 1.11.2 -
运行在以下环境
应用 zend zend_framework 1.11.3 -
运行在以下环境
应用 zend zend_framework 1.11.4 -
运行在以下环境
应用 zend zend_framework 1.11.5 -
运行在以下环境
应用 zend zend_framework 1.11.6 -
运行在以下环境
应用 zend zend_framework 1.11.7 -
运行在以下环境
应用 zend zend_framework 1.11.8 -
运行在以下环境
应用 zend zend_framework 1.11.9 -
运行在以下环境
应用 zend zend_framework 1.12.0 -
运行在以下环境
应用 zend zend_framework 1.12.1 -
运行在以下环境
应用 zend zend_framework 1.12.10 -
运行在以下环境
应用 zend zend_framework 1.12.11 -
运行在以下环境
应用 zend zend_framework 1.12.12 -
运行在以下环境
应用 zend zend_framework 1.12.13 -
运行在以下环境
应用 zend zend_framework 1.12.2 -
运行在以下环境
应用 zend zend_framework 1.12.3 -
运行在以下环境
应用 zend zend_framework 1.12.4 -
运行在以下环境
应用 zend zend_framework 1.12.5 -
运行在以下环境
应用 zend zend_framework 1.12.6 -
运行在以下环境
应用 zend zend_framework 1.12.7 -
运行在以下环境
应用 zend zend_framework 1.12.8 -
运行在以下环境
应用 zend zend_framework 1.12.9 -
运行在以下环境
应用 zend zend_framework 1.5.0 -
运行在以下环境
应用 zend zend_framework 1.5.1 -
运行在以下环境
应用 zend zend_framework 1.5.2 -
运行在以下环境
应用 zend zend_framework 1.5.3 -
运行在以下环境
应用 zend zend_framework 1.6.0 -
运行在以下环境
应用 zend zend_framework 1.6.1 -
运行在以下环境
应用 zend zend_framework 1.6.2 -
运行在以下环境
应用 zend zend_framework 1.7.0 -
运行在以下环境
应用 zend zend_framework 1.7.1 -
运行在以下环境
应用 zend zend_framework 1.7.2 -
运行在以下环境
应用 zend zend_framework 1.7.3 -
运行在以下环境
应用 zend zend_framework 1.7.4 -
运行在以下环境
应用 zend zend_framework 1.7.5 -
运行在以下环境
应用 zend zend_framework 1.7.6 -
运行在以下环境
应用 zend zend_framework 1.7.7 -
运行在以下环境
应用 zend zend_framework 1.7.8 -
运行在以下环境
应用 zend zend_framework 1.7.9 -
运行在以下环境
应用 zend zend_framework 1.8.0 -
运行在以下环境
应用 zend zend_framework 1.8.1 -
运行在以下环境
应用 zend zend_framework 1.8.2 -
运行在以下环境
应用 zend zend_framework 1.8.3 -
运行在以下环境
应用 zend zend_framework 1.8.4 -
运行在以下环境
应用 zend zend_framework 1.8.5 -
运行在以下环境
应用 zend zend_framework 1.9.0 -
运行在以下环境
应用 zend zend_framework 1.9.1 -
运行在以下环境
应用 zend zend_framework 1.9.2 -
运行在以下环境
应用 zend zend_framework 1.9.3 -
运行在以下环境
应用 zend zend_framework 1.9.4 -
运行在以下环境
应用 zend zend_framework 1.9.5 -
运行在以下环境
应用 zend zend_framework 1.9.6 -
运行在以下环境
应用 zend zend_framework 1.9.7 -
运行在以下环境
应用 zend zend_framework 1.9.8 -
运行在以下环境
应用 zend zend_framework 2.0.0 -
运行在以下环境
应用 zend zend_framework 2.0.1 -
运行在以下环境
应用 zend zend_framework 2.0.2 -
运行在以下环境
应用 zend zend_framework 2.0.3 -
运行在以下环境
应用 zend zend_framework 2.0.4 -
运行在以下环境
应用 zend zend_framework 2.0.5 -
运行在以下环境
应用 zend zend_framework 2.0.6 -
运行在以下环境
应用 zend zend_framework 2.0.7 -
运行在以下环境
应用 zend zend_framework 2.1.0 -
运行在以下环境
应用 zend zend_framework 2.1.1 -
运行在以下环境
应用 zend zend_framework 2.1.2 -
运行在以下环境
应用 zend zend_framework 2.1.3 -
运行在以下环境
应用 zend zend_framework 2.1.4 -
运行在以下环境
应用 zend zend_framework 2.1.5 -
运行在以下环境
应用 zend zend_framework 2.1.6 -
运行在以下环境
应用 zend zend_framework 2.2.0 -
运行在以下环境
应用 zend zend_framework 2.2.1 -
运行在以下环境
应用 zend zend_framework 2.2.10 -
运行在以下环境
应用 zend zend_framework 2.2.2 -
运行在以下环境
应用 zend zend_framework 2.2.3 -
运行在以下环境
应用 zend zend_framework 2.2.4 -
运行在以下环境
应用 zend zend_framework 2.2.5 -
运行在以下环境
应用 zend zend_framework 2.2.6 -
运行在以下环境
应用 zend zend_framework 2.2.7 -
运行在以下环境
应用 zend zend_framework 2.2.8 -
运行在以下环境
应用 zend zend_framework 2.2.9 -
运行在以下环境
应用 zend zend_framework 2.3.0 -
运行在以下环境
应用 zend zend_framework 2.3.1 -
运行在以下环境
应用 zend zend_framework 2.3.2 -
运行在以下环境
应用 zend zend_framework 2.3.3 -
运行在以下环境
应用 zend zend_framework 2.3.4 -
运行在以下环境
应用 zend zend_framework 2.3.5 -
运行在以下环境
应用 zend zend_framework 2.3.6 -
运行在以下环境
应用 zend zend_framework 2.3.7 -
运行在以下环境
应用 zend zend_framework 2.3.8 -
运行在以下环境
应用 zend zend_framework 2.3.9 -
运行在以下环境
应用 zend zend_framework 2.4.0 -
运行在以下环境
应用 zend zend_framework 2.4.1 -
运行在以下环境
应用 zend zend_framework 2.4.2 -
运行在以下环境
应用 zend zend_framework 2.4.3 -
运行在以下环境
应用 zend zend_framework 2.4.4 -
运行在以下环境
应用 zend zend_framework 2.4.5 -
运行在以下环境
应用 zend zend_framework 2.5.0 -
运行在以下环境
应用 zend zend_framework 2.5.1 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
1.12.14+dfsg-1
运行在以下环境
系统 fedora_21 php-guzzle-Guzzle * Up to
(excluding)
1.12.16-1.fc21
运行在以下环境
系统 fedora_22 php-guzzle-Guzzle * Up to
(excluding)
1.12.16-1.fc22
运行在以下环境
系统 fedora_23 php-guzzle-Guzzle * Up to
(excluding)
1.12.16-1.fc23
运行在以下环境
系统 fedora_EPEL_6 php-ZendFramework2-I18n * Up to
(excluding)
2.2.10-2.el6
运行在以下环境
系统 fedora_EPEL_7 php-guzzle-Guzzle * Up to
(excluding)
1.12.16-1.el7
运行在以下环境
系统 suse_11 apache2-mod_php53 * Up to
(excluding)
5.3.17-47
阿里云评分
2.5
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    N/A
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况