中危 Pivotal Software Spring Framework任意命令执行漏洞

CVE编号

CVE-2015-5211

利用情况

暂无

补丁情况

官方补丁

披露时间

2017-05-26
漏洞描述
Pivotal Software Spring Framework是美国Pivotal Software公司的一套开源的Java、Java EE应用程序框架。该框架可帮助开发人员构建高质量的应用。

Pivotal Software Spring Framework中存在任意命令执行漏洞。攻击者可利用该漏洞在受影响应用程序上下文中执行任意命令。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:
http://www.spring.io/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 pivotal_software spring_framework 3.2.0 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.1 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.10 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.11 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.12 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.13 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.14 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.2 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.3 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.4 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.5 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.6 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.7 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.8 -
运行在以下环境
应用 pivotal_software spring_framework 3.2.9 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.0 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.1 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.2 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.3 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.4 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.5 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.6 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.7 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.8 -
运行在以下环境
应用 pivotal_software spring_framework 4.0.9 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.0 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.1 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.2 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.3 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.4 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.5 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.6 -
运行在以下环境
应用 pivotal_software spring_framework 4.1.7 -
运行在以下环境
应用 pivotal_software spring_framework 4.2.0 -
运行在以下环境
应用 pivotal_software spring_framework 4.2.1 -
运行在以下环境
系统 debian DPKG * Up to
(excluding)
4.1.9-1
运行在以下环境
系统 debian_8 libspring-java * Up to
(excluding)
3.0.6.RELEASE-17+deb8u1
运行在以下环境
系统 fedora_21 libspring-java * Up to
(excluding)
3.2.15-1.fc21
运行在以下环境
系统 fedora_22 libspring-java * Up to
(excluding)
3.2.15-1.fc22
运行在以下环境
系统 fedora_23 libspring-java * Up to
(excluding)
3.2.15-1.fc23
运行在以下环境
系统 ubuntu_18.04.5_lts libspring-java * Up to
(excluding)
4.3.14-1
运行在以下环境
系统 ubuntu_18.10 libspring-java * Up to
(excluding)
4.3.14-1
阿里云评分
4.5
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-552 对外部实体的文件或目录可访问
阿里云安全产品覆盖情况