Puppet Enterprise Console Parameter 跨站脚本攻击

CVE编号

CVE-2015-6502

利用情况

暂无

补丁情况

N/A

披露时间

2017-12-12
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是一个企业版。console是其中的一个控制台工具。

Puppet Enterprise 2015.2.1之前的版本中的console存在跨站脚本漏洞。远程攻击者可借助‘string’参数利用该漏洞注入任意的Web脚本或HTML。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://puppet.com/security/cve/CVE-2015-6502
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * Up to
(excluding)
2015.2.1
CVSS3评分
6.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况